Bug 716323 - iscsiadm fails to connect while using hostname except of ip address
iscsiadm fails to connect while using hostname except of ip address
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: iscsi-initiator-utils (Show other bugs)
5.6
i686 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Mike Christie
Bruno Goncalves
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-23 20:06 EDT by Jean-Francois Saucier
Modified: 2012-02-21 01:36 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-21 01:36:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jean-Francois Saucier 2011-06-23 20:06:04 EDT
Description of problem:

This is the same problem as bug #624437 reported on RHEL 6. The work is done on a fully updated (as of June 23th) RHEL 5.6 32bits. I searched for the RHEL 5 bug but I found none.

If one follow the KB at https://access.redhat.com/kb/docs/DOC-6388 with hostname, he will get "iscsiadm: no records found!" when trying to login.

Changing for IP address fix the issue, like on the RHEL 6 bug.


Version-Release number of selected component (if applicable):

iscsi-initiator-utils-6.2.0.872-6.el5


How reproducible:

Everytime


Steps to Reproduce:
1.Install a fully updated RHEL 5.6
2.Discover the target with hostname
3.Try to login at the target with the hostname
  

Actual results:

iscsiadm: no records found!


Expected results:

Succesful login to the iSCSI target


Additional info:

None
Comment 1 Mike Christie 2011-06-23 21:36:35 EDT
Sorry about that.

Same thing happened as in bz 624437. When modifying the spec file the patch that implemented this feature got dropped by accident. This will get fixed in 5.8.
Comment 4 Bruno Goncalves 2012-01-17 05:36:04 EST
This issue is fixed within the most recent version, iscsi-initiator-utils-6.2.0.872-13.el5.
Comment 5 errata-xmlrpc 2012-02-21 01:36:48 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0263.html

Note You need to log in before you can comment on or make changes to this bug.