This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 716356 - the <control> click of gedit icon in gnome3 shell doesnt launch new instance of gedit just another tab
the <control> click of gedit icon in gnome3 shell doesnt launch new instance ...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gedit (Show other bugs)
16
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-24 02:13 EDT by collura
Modified: 2013-02-13 16:42 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-13 16:42:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description collura 2011-06-24 02:13:14 EDT
Description of problem:

   when click the gedit icon the gedit program opens, yay.
   when <control>click the gedit icon again 
   a new tab opens in the existing gedit  
   instead of opening a new instance of gedit with its own group of tabs

Version-Release number of selected component (if applicable):

   gedit-3.0.5-1.f15 (x86_64)

How reproducible:

   always

Steps to Reproduce:
1. click on gedit icon to launch gedit
2. hold <control> key while click on gedit icon to launch another gedit
3. repeat until you realize that its not opening new gedits but new tabs instead
4. bootup 3 more workstations so you can separate your tasks a bit
  
Actual results:

   <control>click of gedit icon opens new tabs in existing gedit 
   making it impossible to organize various tasks into groups 
   because they are all in one window.

Expected results:

   <control>click of gedit icon opens a new instance of gedit in its own window so it can have is own set of tabs unrelated to the other instances of gedit and their own sets of tabs. 

Additional info:

   had both gnome-shell-extensions-dock and awn installed at time 
   but the problem only seemed to be with gedit not the other programs i tried.

   thought that this might have been by gnome3 shell design forced-simplicity
   issue but it is not consistent with 
   some other programs responses in gnome3 shell. 

   for example, the <control>click launched separate instances of calculators
   and terminals from the dock as expected, though wouldnt with gedits.

   (i like the 'trying to be simpler' idea but this giant pile of files 
   approach is disorganized and thus not helpful so filing this bug.)
Comment 1 collura 2011-11-02 23:07:52 EDT
the gnome3-ish <control><click>launch still no work as of f16-gnome-rc2

  gedit-2:3.2.1-1.fc16 (64bit)

( though the [cool_alternate_launch_method / temporary_workaround] 
to drag the new gedit tab off of gedit to desktop 
to generate its own window is actually easier, lol. )
Comment 2 Fedora End Of Life 2013-01-16 12:14:18 EST
This message is a reminder that Fedora 16 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 16. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '16'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 16's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 16 is end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" and open it against that version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Fedora End Of Life 2013-02-13 16:42:22 EST
Fedora 16 changed to end-of-life (EOL) status on 2013-02-12. Fedora 16 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.