Bug 71646 - emacs-21.2-16: man pages not formatted properly
emacs-21.2-16: man pages not formatted properly
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: emacs (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Jay Turner
:
: 72277 73268 (view as bug list)
Depends On:
Blocks: 67218
  Show dependency treegraph
 
Reported: 2002-08-15 22:25 EDT by Jonathan Kamens
Modified: 2015-01-07 18:59 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-03 11:32:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2002-08-15 22:25:38 EDT
After upgrading to all the current Raw Hide packages, including emacs-21.2-16
and groff-1.18-4, man pages viewed in Emacs with M-x man are no longer formatted
properly -- they contain a bunch of terminal escapes starting with ^[.

M-x woman does the right thing, but I don't want to use M-x woman, and in any
case, M-x man should work.
Comment 1 Trond Eivind Glomsrxd 2002-08-16 12:59:57 EDT
When using the groff from RHL 7.3, it works. What's changed, Florian?
Comment 2 Florian La Roche 2002-08-27 08:22:39 EDT
Teg, how is the man-page formatted: Is man called or groff directly?
Is the same command working on the commandline, but not within *emacs?

In general you need "-Tutf8" for groff to specify the correct output.

Thanks,

Florian La Roche
Comment 3 Trond Eivind Glomsrxd 2002-08-29 12:28:46 EDT
It calls man. Switching values (replacing lating 1 with utf8) in /etc/man.config
didn't help. Using 7.3 groff OTOH eliminates the problem (same issue as xemacs)
Comment 4 Trond Eivind Glomsrxd 2002-08-29 17:35:17 EDT
The problem is that groff no longer uses the output format it used to, it now
uses ANSI escape sequences.
Comment 5 Trond Eivind Glomsrxd 2002-08-29 18:06:21 EDT
Adding a -c to the nroff invocation in /etc/man.config will fix that... bero?
Comment 6 Trond Eivind Glomsrxd 2002-08-29 18:57:54 EDT
*** Bug 72277 has been marked as a duplicate of this bug. ***
Comment 7 Trond Eivind Glomsrxd 2002-09-03 11:24:12 EDT
*** Bug 73268 has been marked as a duplicate of this bug. ***
Comment 8 Trond Eivind Glomsrxd 2002-09-03 11:31:54 EDT
Fixed in 1.5j-10, built by notting
Comment 9 Jay Turner 2002-09-04 10:59:50 EDT
Fix confirmed with man-1.5j-11.

Note You need to log in before you can comment on or make changes to this bug.