Bug 71653 - Installer error "Cannot allocate memory"
Installer error "Cannot allocate memory"
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-16 00:54 EDT by ncc33843
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-19 18:42:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ncc33843 2002-08-16 00:54:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)

Description of problem:
When I have been through the installer selecting the options just after setting 
up the RPM transactions it brings up an error message (see below)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Boot from first CD
2.Select any options from the menu (tried many different combinations, same 
error every time)
3.Await the error message
	

Actual Results:  The installer brought up an error message it told me to make 
against anaconda with the main message that it could not allocate memory

Expected Results:  Red Hat liux should have installed onto the partitioned drive

Additional info:

It brought up the following error message (may not be 100% exact, it would not 
copy it to a floppy disk to I had to write it down and type it up again)

Traceback (innermost last);
File "/user/bin/anaconda", line 633 in ?
  intf.run(id, dispatched, configFileData)
File "/usr/lib/anaconda/gui.py", line 353 in
  run self.icw.run (slef.runres, configFileData)
File "/usr/lib/python1.5/site-packages/gtk.py", line 2676, in
  mainloop _gtk.gtk_main()
File "/usr/lib/anaconda/gui.py", line 529, in
  handleRenderCallback self.currentWindow.renderCallback()
File "/usr/lib/anaconda/iw/progress_gui.py", line 135 in
  renderCallback self.intf.icw.nextClicked()
File "/usr/lib/anaconda/gui.py", line 417 in
  nextrClicked self.dispatch.gotoNext()
File "/usr/lib/anaconda/dispatch.py", line 144 in
  gotoNext self.moveStep()
File "/usr/lib/anaconda/packages.py", line 209 in
  moveStep rc = apply(func, self_bindArgs(args))
File "/usr/lib/anaconda/packages.py", line 573 in
  doInstall syslog.start(instPath, syslogname)
File "/usr/lib/anaconda/syslogd.py", line 63 in
start self.pid = os.fork
OSError:[Errno 12] Cannot allocate memory
Comment 1 Michael Fulbright 2002-08-19 12:06:35 EDT
How much RAM is in your system?

How much swap did you allocate?
Comment 2 ncc33843 2002-08-19 18:41:54 EDT
The computer I tried to install it on was a PII 266Mhz with 64Mb RAM installing 
it on a 2.5Gb ext2 partition, it mentioned after I selected what drive to 
install Linux to that I had not specified a swap but it said that it was not 
nessisary, how would I go about allocating this?
Comment 3 Michael Fulbright 2002-08-23 11:55:14 EDT
I would recommend adding at least 128M of swap for the amount of RAM you have,
192M would not hurt.

Note You need to log in before you can comment on or make changes to this bug.