Bug 71659 - KDM cannot start window managers
Summary: KDM cannot start window managers
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
high
high
Target Milestone: ---
Assignee: Petr Rockai
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-16 12:31 UTC by Chris Ricker
Modified: 2005-10-31 22:00 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-14 14:45:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Ricker 2002-08-16 12:31:00 UTC
I'm using KDM as my display manager.  I have a user who is configured to start,
by default, the fluxbox window manager when he logs in (ie, ~/.Xclients-default
contains "exec fluxbox").  When this user logs into kdm the first time, kdm
starts the X server (stippled grey background comes up), and then crashes out of
X back into kdm.  When this user then logs into kdm the second time, kdm
correctly starts up X and fluxbox.

This appears to be a race condition with kdm misordering X authentication setup
the first time, since the X server log file contains, after the first failed X
startup, lots of messages which look like:

AUDIT: Fri Aug 16 06:14:33 2002: 930 X: client 2 rejected from local host

Presumably, kdm is execing ~/.Xclients-default before all the Xauth stuff is
correctly configured....  This is on a relatively slow machine (K6-III 600), so
it might be due to the slow CPU.

Comment 1 Chris Ricker 2002-08-24 13:09:01 UTC
This is still true in beta5

Comment 2 Chris Ricker 2002-08-24 13:12:15 UTC
This bug appears to be universal.  I see a similar thing on a faster system
(Athlon 650).  On a stock beta5 system, I created a user, logged in as that
user, and ran switchdesk and selected twm.  I then tried to log in through kdm.
 It started the X server, painted the background blue, then failed to start twm.
 No errors were logged this time.

kdm is completely unusable because of this bug -- it apparently cannot start any
environment except KDE / GNOME

Comment 3 Chris Ricker 2002-08-31 15:03:59 UTC
This still happens with kdebase-3.0.3-6

Furthermore, now that I've started testing out KDE, it appears to be universal
even for KDE / GNOME.  The very first time I boot my system, logins to kdm work
but fail to start the environment (KDE / GNOME / any wm).  All subsequent logins
will work, until I reboot.

Comment 4 Ngo Than 2005-02-14 14:45:49 UTC
as i know it's fixed in current fc3 (or fc2)


Note You need to log in before you can comment on or make changes to this bug.