Bug 71661 - NFS performs extremely slow 200~300k/s
NFS performs extremely slow 200~300k/s
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel (Show other bugs)
2.1
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Larry Woodman
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-16 08:52 EDT by geekjim
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-31 08:12:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description geekjim 2002-08-16 08:52:03 EDT
NFS server and clients are connected with a single 3com 1700 giga switch. All 
machines are installed with broadcom giga network adapter.

OS: Both sides are Red Hat AS 2.1 with updated kernel from Red Hat, 2.4.9-e.8

No other special configuration.

NFS start and mount normally. But transfer speed is quite slow, only 
200~300KB/s. ifconfig shows no erros, drops, overruns...

I am sure it's not network problem, ftp, sftp, ftp runs normally 
and fast.

I Have tried to:
set rsize,wsize to 8k or 32k
set sync, async
set nfsvers=3
None of the above works.

I think it's a Kernel problem
Comment 1 geekjim 2002-08-16 17:44:19 EDT
After upgrading kernel to 2.4.18-7, the problem was solved.
Transfer speed bursts upto 40MB/s under mount option as:

mount -o rw -o nfsvers=3 -o tcp -o hard -o async -o rsize=32768 -o wsize=32768
Comment 2 Larry Woodman 2003-06-23 13:48:57 EDT
Lots of NFS performance work was done to AS2.1 over the past
several kernel errata.  Is this still a problem with the e.24
kernel?

Larry Woodman
Comment 3 Arjan van de Ven 2003-07-31 08:12:38 EDT
closing due to inactivity

Note You need to log in before you can comment on or make changes to this bug.