Bug 717161 - SELinux is preventing /usr/sbin/pppd from 'search' accesses on the directory /var/lock.
Summary: SELinux is preventing /usr/sbin/pppd from 'search' accesses on the directory ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 15
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:31ac964cb9a...
: 712136 716279 717445 717826 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-06-28 08:29 UTC by Hicham HAOUARI
Modified: 2011-07-08 18:11 UTC (History)
8 users (show)

Fixed In Version: selinux-policy-3.9.16-32.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-07-08 18:11:28 UTC


Attachments (Terms of Use)

Description Hicham HAOUARI 2011-06-28 08:29:45 UTC
SELinux is preventing /usr/sbin/pppd from 'search' accesses on the directory /var/lock.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that pppd should be allowed search access on the lock directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep pppd /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:pppd_t:s0
Target Context                system_u:object_r:var_lock_t:s0
Target Objects                /var/lock [ dir ]
Source                        pppd
Source Path                   /usr/sbin/pppd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           ppp-2.4.5-17.fc15
Target RPM Packages           filesystem-2.4.41-1.fc15
Policy RPM                    selinux-policy-3.9.16-30.fc15
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 2.6.38.8-32.fc15.i686 #1 SMP
                              Mon Jun 13 20:01:50 UTC 2011 i686 i686
Alert Count                   11
First Seen                    Sat 25 Jun 2011 10:57:16 PM WEST
Last Seen                     Tue 28 Jun 2011 09:21:49 AM WEST
Local ID                      c34a9c57-0e03-4d05-9b1e-1c72a3820749

Raw Audit Messages
type=AVC msg=audit(1309249309.975:34): avc:  denied  { search } for  pid=1256 comm="pppd" name="lock" dev=tmpfs ino=6222 scontext=system_u:system_r:pppd_t:s0 tcontext=system_u:object_r:var_lock_t:s0 tclass=dir


type=SYSCALL msg=audit(1309249309.975:34): arch=i386 syscall=open success=yes exit=EAGAIN a0=bf4760 a1=800c2 a2=1a4 a3=bf4760 items=0 ppid=658 pid=1256 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=pppd exe=/usr/sbin/pppd subj=system_u:system_r:pppd_t:s0 key=(null)

Hash: pppd,pppd_t,var_lock_t,dir,search

audit2allow

#============= pppd_t ==============
allow pppd_t var_lock_t:dir search;

audit2allow -R

#============= pppd_t ==============
allow pppd_t var_lock_t:dir search;

Comment 1 Hicham HAOUARI 2011-06-28 08:36:58 UTC
hicham@hicham-laptop ~ $ ls -Z /var/lock
drwxrwxr-x. root lock system_u:object_r:var_lock_t:s0  lockdev
drwxr-xr-x. root root system_u:object_r:pppd_lock_t:s0 ppp
drwxr-xr-x. root root system_u:object_r:var_lock_t:s0  subsys

Comment 2 Miroslav Grepl 2011-06-28 08:50:13 UTC
Fixed in selinux-policy-3.9.16-31.fc15

You can allow it for now using

# grep pppd /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Comment 3 Miroslav Grepl 2011-06-28 15:10:12 UTC
*** Bug 716279 has been marked as a duplicate of this bug. ***

Comment 4 Miroslav Grepl 2011-06-29 08:03:30 UTC
*** Bug 717445 has been marked as a duplicate of this bug. ***

Comment 5 Miroslav Grepl 2011-06-30 07:04:48 UTC
*** Bug 717826 has been marked as a duplicate of this bug. ***

Comment 6 Miroslav Grepl 2011-06-30 07:04:53 UTC
*** Bug 712136 has been marked as a duplicate of this bug. ***

Comment 7 Fedora Update System 2011-06-30 15:59:29 UTC
selinux-policy-3.9.16-31.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/selinux-policy-3.9.16-31.fc15

Comment 8 Fedora Update System 2011-07-01 18:56:00 UTC
Package selinux-policy-3.9.16-32.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.9.16-32.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/selinux-policy-3.9.16-32.fc15
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2011-07-08 18:10:12 UTC
selinux-policy-3.9.16-32.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.