This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 71718 - firstboot fails on boot finding soundcard module
firstboot fails on boot finding soundcard module
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kudzu (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-16 20:40 EDT by cbagwell
Modified: 2014-03-16 22:30 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-19 17:02:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description cbagwell 2002-08-16 20:40:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020804

Description of problem:
I upgraded from RedHat 7.3 to the 1st beta of limbo redhat using a CD.  Then I
upgraded to beta 2 of limbo just using up2date.

I notice in my /var/log/messages file that I keep getting the following new
error message:

Aug 16 18:42:34 brew4me firstboot: Window manager warning: Failed to a open
connection to a session manager, so window positions will not be saved:
SESSION_MANAGER environment variable not defined
Aug 16 18:42:37 brew4me firstboot: in start_existing_X
Aug 16 18:42:37 brew4me firstboot: Screen width is 1152
Aug 16 18:42:37 brew4me firstboot: None
Aug 16 18:42:37 brew4me firstboot: Traceback (most recent call last):
Aug 16 18:42:37 brew4me firstboot:   File "/usr/sbin/firstboot", line 126, in
?Aug 16 18:42:37 brew4me firstboot:     firstbootWindow.firstbootWindow(wm_pid,
doReconfig, doDebug)
Aug 16 18:42:37 brew4me firstboot:   File
"/usr/share/firstboot/firstbootWindow.py", line 88, in __init__
Aug 16 18:42:37 brew4me firstboot:     exec(cmd)
Aug 16 18:42:37 brew4me firstboot:   File "<string>", line 1, in ?
Aug 16 18:42:37 brew4me firstboot:   File
"/usr/share/firstboot/modules/soundcard_gui.py", line 34, in ?
Aug 16 18:42:37 brew4me firstboot:     import soundcard
Aug 16 18:42:37 brew4me firstboot: ImportError: No module named soundcard

I looked at /usr/share/firstboot/modules/soundcard_gui.py and notice it seems to
be a development version since it has the following towards the top which would
confuse were to find modules:

#sys.path.append('/usr/share/redhat-config-soundcard/')
sys.path.append('/home/devel/bfox/redhat/redhat-config-soundcard/src/')

Looking around that directory, it appears most files are symlinks to similar
named files in /usr/share/redhat-config-*.

It looks like the soundcard_gui.* files should be symlinks to files in
/usr/share/redhat-config-soundcard.

root@brew4me { 1076 } >rpm -q -f soundcard_gui.py
firstboot-0.9.7-1


Version-Release number of selected component (if applicable):


How reproducible:
Didn't try


Additional info:
Comment 1 Barry K. Nathan 2004-07-16 06:03:18 EDT
I'm certain this bug was fixed before the release of RHL 8.0. It
should be CLOSED/CURRENTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.