Bug 717528 - [abrt] fedpkg-0.5.9.2-1.fc15: __init__.py:210:_run_command:TypeError: sequence item 3: expected string, NoneType found
Summary: [abrt] fedpkg-0.5.9.2-1.fc15: __init__.py:210:_run_command:TypeError: sequenc...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-packager
Version: 15
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David Cantrell
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:d4653d929244d7362c16af56ed5...
: 738402 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-06-29 06:46 UTC by Vít Ondruch
Modified: 2013-01-10 06:38 UTC (History)
5 users (show)

Fixed In Version: rpkg-1.6-1.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-29 01:39:01 UTC
Type: ---


Attachments (Terms of Use)

Description Vít Ondruch 2011-06-29 06:46:01 UTC
abrt version: 2.0.1
architecture:   x86_64
cmdline:        
component:      fedora-packager
executable:     /usr/bin/fedpkg
kernel:         2.6.38.8-32.fc15.x86_64
os_release:     Fedora release 15 (Lovelock)
package:        fedpkg-0.5.9.2-1.fc15
reason:         __init__.py:210:_run_command:TypeError: sequence item 3: expected string, NoneType found
time:           Wed Jun 29 08:24:18 2011
uid:            500
username:       vondruch

backtrace:
:__init__.py:210:_run_command:TypeError: sequence item 3: expected string, NoneType found
:
:Traceback (most recent call last):
:  File "/usr/bin/fedpkg", line 1495, in <module>
:    args.command(args)
:  File "/usr/bin/fedpkg", line 721, in tag
:    pyfedpkg.list_tag(args.tag)
:  File "/usr/lib/python2.7/site-packages/pyfedpkg/__init__.py", line 750, in list_tag
:    _run_command(cmd)
:  File "/usr/lib/python2.7/site-packages/pyfedpkg/__init__.py", line 210, in _run_command
:    ' '.join(cmd))
:TypeError: sequence item 3: expected string, NoneType found
:
:Local variables in innermost frame:
:shell: False
:cmd: ['git', 'tag', '-l', None]
:pipe: []
:pipecmd: []
:environ: {'GIT_PS1_SHOWDIRTYSTATE': 'true', 'GNOME_DESKTOP_SESSION_ID': 'this-is-deprecated', 'GJS_DEBUG_OUTPUT': 'stderr', 'LESSOPEN': '||/usr/bin/lesspipe.sh %s', 'QT_IM_MODULE': 'xim', 'LOGNAME': 'vondruch', 'USER': 'vondruch', 'GNOME_KEYRING_CONTROL': '/tmp/keyring-05R1vz', 'PATH': '/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/vondruch/bin', 'PS1': '[\\u@\\h \\W$(__git_ps1 " (%s)")]\\$ ', 'WINDOWPATH': '7', 'LANG': 'cs_CZ.utf8', 'TERM': 'xterm', 'SHELL': '/bin/bash', 'XDG_SESSION_COOKIE': '9b15f55cdaaaad703afa73da0000001e-1308890641.504171-1082815575', 'SESSION_MANAGER': 'local/unix:@/tmp/.ICE-unix/3377,unix/unix:/tmp/.ICE-unix/3377', 'SHLVL': '2', 'G_BROKEN_FILENAMES': '1', 'HISTSIZE': '1000', 'WINDOWID': '35778033', '_': '/usr/bin/fedpkg', 'IMSETTINGS_INTEGRATE_DESKTOP': 'yes', 'GPG_AGENT_INFO': '/tmp/keyring-05R1vz/gpg:0:1', 'HOME': '/home/vondruch', 'CVSROOT': ':gserver:cvs.devel.redhat.com:/cvs/dist', 'USERNAME': 'vondruch', 'IMSETTINGS_MODULE': 'IBus', 'XDG_RUNTIME_DIR': '/run/user/vondruch', 'SSH_AUTH_SOCK': '/tmp/keyring-05R1vz/ssh', 'GDMSESSION': 'gnome', 'XMODIFIERS': '@im=ibus', 'XDG_SESSION_ID': '2', 'DBUS_SESSION_BUS_ADDRESS': 'unix:abstract=/tmp/dbus-vwcxEtx9FS,guid=8875c241c9756bcf3d68cf3300000289', 'ORBIT_SOCKETDIR': '/tmp/orbit-vondruch', 'XAUTHORITY': '/var/run/gdm/auth-for-vondruch-ZSyORs/database', 'DESKTOP_SESSION': 'gnome', 'GIT_PS1_SHOWUNTRACKEDFILES': 'true', 'DISPLAY': ':0', 'GNOME_KEYRING_PID': '3369', 'OLDPWD': '/home/vondruch/fedora-scm/own', 'HOSTNAME': 'dhcp-25-40.brq.redhat.com', 'GDM_LANG': 'cs_CZ.utf8', 'HISTCONTROL': 'ignoredups', 'PWD': '/home/vondruch/fedora-scm/own/rubygem-railties', 'CVS_RSH': 'ssh', 'COLORTERM': 'gnome-terminal', 'MAIL': '/var/spool/mail/vondruch', 'LS_COLORS': 'rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:mi=01;05;37;41:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.lz=01;31:*.xz=01;31:*.bz2=01;31:*.tbz=01;31:*.tbz2=01;31:*.bz=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.war=01;31:*.ear=01;31:*.sar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.axv=01;35:*.anx=01;35:*.ogv=01;35:*.ogx=01;35:*.aac=01;36:*.au=01;36:*.flac=01;36:*.mid=01;36:*.midi=01;36:*.mka=01;36:*.mp3=01;36:*.mpc=01;36:*.ogg=01;36:*.ra=01;36:*.wav=01;36:*.axa=01;36:*.oga=01;36:*.spx=01;36:*.xspf=01;36:', 'GJS_DEBUG_TOPICS': 'JS ERROR;JS LOG'}
:env: None
:command: ['git', 'tag', '-l', None]
:cwd: None

Comment 1 Jesse Keating 2011-06-30 16:30:29 UTC
Interesting, will look into it.

Comment 2 Bojan Smojver 2011-08-11 02:06:09 UTC
Package: fedpkg-0.5.9.2-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)

Comment
-----
Attempted to list tags.

Comment 3 Jesse Keating 2011-09-08 23:46:25 UTC
Fixed this upstream, will be in the next builds.

Comment 4 Jesse Keating 2011-09-14 23:54:54 UTC
*** Bug 738402 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Update System 2011-09-19 23:06:01 UTC
rpkg-1.5-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/rpkg-1.5-1.fc16

Comment 6 Fedora Update System 2011-09-19 23:08:10 UTC
rpkg-1.5-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/rpkg-1.5-1.fc15

Comment 7 Fedora Update System 2011-09-19 23:08:57 UTC
rpkg-1.5-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/rpkg-1.5-1.el6

Comment 8 Fedora Update System 2011-09-20 02:32:59 UTC
Package rpkg-1.5-1.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing rpkg-1.5-1.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/rpkg-1.5-1.el6
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2011-09-20 22:04:45 UTC
rpkg-1.6-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/rpkg-1.6-1.fc16

Comment 10 Fedora Update System 2011-09-20 22:10:34 UTC
rpkg-1.6-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/rpkg-1.6-1.el6

Comment 11 Fedora Update System 2011-09-29 01:38:49 UTC
rpkg-1.5-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2011-09-30 18:33:39 UTC
rpkg-1.6-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.