This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 717887 - Rebase to match latest libvirt version to support all new APIs
Rebase to match latest libvirt version to support all new APIs
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: perl-Sys-Virt (Show other bugs)
6.0
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Daniel Berrange
Virtualization Bugs
: Rebase
Depends On:
Blocks: 693512
  Show dependency treegraph
 
Reported: 2011-06-30 06:17 EDT by Daniel Berrange
Modified: 2011-12-06 06:49 EST (History)
7 users (show)

See Also:
Fixed In Version: perl-Sys-Virt-0.9.4-2.el6
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
The Perl binding for libvirt is being updated to provide support for all new APIs added to libvirt, since the previous release.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 06:49:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2011-06-30 06:17:34 EDT
Description of problem:
The libvirt library has been updated in RHEL6, introducing many new APIs. perl-Sys-Virt needs to be rebased to a matching version to support all these new APIs.

Version-Release number of selected component (if applicable):
0.2.5-1.el6

How reproducible:
N/A

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 Daniel Berrange 2011-06-30 08:33:24 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
The Perl binding for libvirt is being updated to provide support for all new APIs added to libvirt, since the previous release.
Comment 3 Daniel Berrange 2011-07-12 04:50:06 EDT
perl-Sys-Virt-0.9.2-1.el6 is built in RHEL-6.2-candidate    berrange
[berrange@t500wlan ~]$ 


A further update to 0.9.4 is anticipated prior to the final feature freeze, to match the final anticipated libvirt  version
Comment 5 Daniel Berrange 2011-08-03 10:51:50 EDT
Move back to assigned for the 0.9.4 rebuild
Comment 7 xhu 2011-10-28 03:56:18 EDT
Compared with perl-Sys-Virt-0.9.4-1.el6, there is 23 new API in perl-Sys-Virt-0.9.4-2.el6 and the details can be seen as follows:

define_save_image_xml, 
dom->abort_block_job
dom->block_pull	
dom->get_blkio_parameters
dom->get_block_job_info
dom->get_control_info
dom->get_state
dom->inject_nmi
dom->migrate_set_max_speed
dom->screenshot
dom->send_key
dom->set_blkio_parameters
dom->set_block_job_speed
get_node_cpu_stats
get_node_memory_stats
get_save_image_xml_description
get_sysinfo
interface_change_begin
interface_change_commit
interface_change_rollback
new_stream
vol->download
vol->upload

We test all the above 23 new API: there is 2 not fine API(get_node_cpu_stats and get_node_memory_stats) and file bug 748689: https://bugzilla.redhat.com/show_bug.cgi?id=748689 to track.

So change this bug to verify status.
Comment 8 errata-xmlrpc 2011-12-06 06:49:05 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1573.html

Note You need to log in before you can comment on or make changes to this bug.