Bug 718207 - fence_ilo fails silently when pyOpenSSL is not installed
fence_ilo fails silently when pyOpenSSL is not installed
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: fence-agents (Show other bugs)
6.2
x86_64 Unspecified
medium Severity medium
: rc
: ---
Assigned To: Fabio Massimo Di Nitto
Cluster QE
:
Depends On: 698002
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-01 08:01 EDT by Marek Grac
Modified: 2011-12-06 07:22 EST (History)
7 users (show)

See Also:
Fixed In Version: fence-agents-3.1.5-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 698002
Environment:
Last Closed: 2011-12-06 07:22:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marek Grac 2011-07-01 08:01:05 EDT
+++ This bug was initially created as a clone of Bug #698002 +++

Description of problem:

The cman RPM does not depend on pyOpenSSL, and fence_ilo simply fails with "Unable to connect/login to fencing device", regardless if '-v' or '-D /tmp/foo' are passed. This makes it very difficult to sort out what is wrong.

It is true that the fence_ilo man page indicates that this is a required package, but it is easily missed when people skip the DESCRIPTION section and go right to reading the switches.

Version-Release number of selected component (if applicable):

cman-2.0.115-68.el5.x86_64
fence_ilo: FENCE_RELEASE_NAME="2.0.115";

How reproducible:

100%

Steps to Reproduce:
1. Uninstall pyOpenSSL
2. Run 'fence_ilo -a <ip> -l <user> -p <pass> -o reboot
3.
  
Actual results:

Fails with a generic error message

Expected results:

Report that a dependent package is missing.

Additional info:

--- Additional comment from zidek@master.cz on 2011-05-24 06:52:05 EDT ---

cman should be dependent on pyOpenSSL. Today I run into huge problems after cluster split brain condition with this error.
Comment 1 digimer 2011-07-01 12:08:05 EDT
You created an identical Bug #718208 against RHEL 5.6. Did you test against both distribution versions?
Comment 6 Radek Steiger 2011-10-18 06:52:51 EDT
Marking as VERIFIED for fence-agents-3.1.5-10.el6

Since the only change is the rpm package dependency list, tested simply by calling:

[root@z1 tmp]# rpm -e pyOpenSSL
error: Failed dependencies:
	pyOpenSSL is needed by (installed) rhnlib-2.5.22-12.el6.noarch
	pyOpenSSL is needed by (installed) fence-agents-3.1.5-10.el6.i686
	pyOpenSSL is needed by (installed) python-paste-1.7.4-1.el6.noarch
	pyOpenSSL is needed by (installed) python-paste-script-1.7.3-4.el6.noarch


The rpm error clearly shows that pyOpenSSL cannot be removed without removing fence-agents as well, therefore solves the original issue.
Comment 7 errata-xmlrpc 2011-12-06 07:22:58 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1599.html

Note You need to log in before you can comment on or make changes to this bug.