Bug 718436 - SSSD calls system() to flush NSCD caching services.
SSSD calls system() to flush NSCD caching services.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: sssd (Show other bugs)
15
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Stephen Gallagher
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-02 19:17 EDT by Matthew Ife
Modified: 2011-07-25 23:39 EDT (History)
4 users (show)

See Also:
Fixed In Version: sssd-1.5.11-2.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-25 23:33:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Ife 2011-07-02 19:17:55 EDT
Description of problem:

In an attempt to flush NSCD if it is running, SSSD will call system(/usr/bin/nscd -i service) to flush the cache.

This is a problem from a SELinux standpoint because future policy writers will need to allow the sss-tools to have execute permission of all bin_t files.

It is preferable to directly fork/exec in this situation because then SELinux policy can support the nscd_domtrans call only which greatly reduces the scope of access required to make this work.

Version-Release number of selected component (if applicable):

sssd-1.5.8

How reproducible:

Consistently reproduceable.

Steps to Reproduce:
1. Call any sss-tools application which alters the local database files.

Actual results:

The request works but SELinux polic would need to permit execute on bin_t types.

Expected results:

No requirement to execute bin_t types when calling nscd.
Comment 1 Fedora Update System 2011-07-05 15:40:17 EDT
sssd-1.5.11-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/sssd-1.5.11-2.fc15
Comment 2 Fedora Update System 2011-07-05 15:40:18 EDT
sssd-1.5.11-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/sssd-1.5.11-2.fc14
Comment 3 Fedora Update System 2011-07-06 17:27:23 EDT
Package sssd-1.5.11-2.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing sssd-1.5.11-2.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/sssd-1.5.11-2.fc15
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2011-07-25 23:33:15 EDT
sssd-1.5.11-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2011-07-25 23:39:21 EDT
sssd-1.5.11-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.