Bug 71866 - Can't login when using dhcp
Can't login when using dhcp
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: dhcp (Show other bugs)
7.3
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-19 17:48 EDT by Paul Davis
Modified: 2007-04-18 12:45 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-01 15:37:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Davis 2002-08-19 17:48:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76C-CCK-MCD  [en] (X11; U; SunOS 5.8 sun4u)

Description of problem:
Can't login when using dhcp. Graphical login dumps out to text login after
entering password, then can login. If network is disconnected, then graphical
login works fine.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot Linux w/dhcp
2. Attempt to login at graphical login window.
3. Next find oneself at a text login prompt.
	

Actual Results:  see above

Expected Results:  login worked correctly

Additional info:

If network is disconnected, then graphical login works fine.
Comment 1 Olivier Baudron 2002-08-20 09:14:06 EDT
What's your dhcp client? What are the messages related to it at boot time?
Do you have gnome/kde?
Comment 2 Paul Davis 2002-08-20 11:57:31 EDT
What's your dhcp client?

 - Not sure what you're asking. This is a fresh 7.3 install. Selected "dhcp" and
"activate at boot" during install, so "dhcp client" is the default RH 7.3 dhcp
client (I haven't changed/added anything)

What are the messages related to it at boot time?
 - No actual messages. Login screen says localhost.localdomain before logging
in. Then when attempt to login, it just dumps out to a text login prompt
"localhost login: ". Now when I login I get a shell prompt
"pdavis@dhcp-ngw03-249-191". The hostname has changed which is likely the
problem in some way.

Here's the tail end of the messages file when I booted and duplicated problem:

Aug 20 09:36:58 localhost xfs: xfs startup succeeded
Aug 20 09:36:58 localhost anacron: anacron startup succeeded
Aug 20 09:36:58 localhost xfs: ignoring font path element
/usr/X11R6/lib/X11/fonts/cyrillic (unreadable
) 
Aug 20 09:36:58 localhost xfs: ignoring font path element
/usr/X11R6/lib/X11/fonts/CID (unreadable) 
Aug 20 09:36:58 localhost xfs: ignoring font path element
/usr/X11R6/lib/X11/fonts/local (unreadable) 
Aug 20 09:36:58 localhost xfs: ignoring font path element
/usr/X11R6/lib/X11/fonts/latin2/Type1 (unread
able) 
Aug 20 09:36:58 localhost atd: atd startup succeeded
Aug 20 09:36:59 localhost wine: Registering binary handler for Windows
applications
Aug 20 09:37:00 localhost rc: Starting wine:  succeeded
Aug 20 09:37:09 localhost kernel: eth0: flipped to 10baseT
Aug 20 09:37:19 localhost logger: punching nameserver 129.147.62.1 through the
firewall
Aug 20 09:37:19 localhost logger: punching nameserver 129.147.62.14 through the
firewall
Aug 20 09:37:19 localhost logger: punching nameserver 129.147.62.14 through the
firewall
Aug 20 09:37:19 localhost logger: punching nameserver 129.147.62.15 through the
firewall
Aug 20 09:40:33 localhost gdm(pam_unix)[1164]: session opened for user pdavis by
(uid=0)
Aug 20 09:40:34 localhost gdm(pam_unix)[1164]: session closed for user pdavis
Aug 20 09:40:35 localhost gdm[1164]: gdm_auth_secure_display: Error getting
hentry for dhcp-ngw03-249-1
91
Aug 20 09:40:35 localhost gdm[1156]: gdm_child_action: Aborting display :0
Aug 20 09:41:44 localhost login(pam_unix)[1150]: session opened for user pdavis
by LOGIN(uid=0)
Aug 20 09:41:44 localhost  -- pdavis[1150]: LOGIN ON tty1 BY pdavis
Aug 20 09:44:38 localhost su(pam_unix)[1704]: session opened for user root by
pdavis(uid=500)


Do you have gnome/kde?
 - gnome installed only

Comment 3 Olivier Baudron 2002-08-20 13:20:59 EDT
Normally, things should go like this:
- dhcpcd receives a host name from the server and sets it with sethostname()
- gdm calls gethostbyname() on it.
But it fails at this point, and I don't know why...
Comment 4 Olivier Baudron 2002-08-20 13:57:19 EDT
Could you tell me how is your network? (ISP, firewalls, name server, dhcp
server, ...)
Comment 5 Paul Davis 2002-08-20 18:30:32 EDT
Could you tell me how is your network? (ISP, firewalls, name server, dhcp
 server, ...)

No ISP or firewalls involved, using local corporate network.

Here's the data dhcp is passing (becoming more convinced that it's in the local
dhcp):


Name                    Type            Value
==================================================
pyramid                 Macro          
:Include=Locale:Timeserv=129.147.249.1:LeaseTim=14400:LeaseNeg:DNSdmain="Central.Sun.COM":DNSserv=129.147.62.1
129.147.62.14 129.147.62.15:NetBNms=129.147.249.4:
129.147.97.0            Macro          
:Subnet=255.255.255.0:Router=129.147.97.248:Broadcst=129.147.97.255:NISdmain="rockymtn.Central.Sun.COM":NISservs=129.147.249.1:
129.147.249.0           Macro          
:Subnet=255.255.255.0:Router=129.147.249.254:Broadcst=129.147.249.255:NISdmain="rockymtn.Central.Sun.COM":NISservs=129.147.249.1:
Locale                  Macro           :UTCoffst=-25200:
Comment 6 Olivier Baudron 2002-08-20 19:06:32 EDT
No, the problem is that in gdm, gethostbyname("dhcp-ngw03-249-191") fails.
But I don't have enough knowledge to say why. How the FQDN is retrieved before
the DNS query is done remains mysterious to me...
Comment 7 Olivier Baudron 2002-08-21 08:56:18 EDT
What is your /etc/resolv.conf ?
Comment 8 Paul Davis 2002-08-21 10:46:20 EDT
Very strange. Problem seems resolved. Tried it all again today. Works now, but
the behavior is:

After boot, graphical login screen says "Welcome to localhost.localdomain". Try
logging in and screen blanks out for a few seconds and then we return back to
the login screen. Now it says "Welcome to dhcp-ngw03-xxx-xxx" (has picked up the
new dchp name). Now can successfully log in.

I'm happy enough if it works, but is this the normal behavior w/dhcp?

Thanks.
Comment 9 Elliot Lee 2002-08-26 07:41:07 EDT
My real question would be why gdm is getting to the login screen before dhcp has done all 
its magic gunk with the hostname.

Note You need to log in before you can comment on or make changes to this bug.