This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 718895 - mozplugger - PDF's fail to load in browser window.
mozplugger - PDF's fail to load in browser window.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mozplugger (Show other bugs)
14
i686 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-04 23:07 EDT by Randall "Randy" Berry
Modified: 2011-07-05 17:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-05 17:46:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Randall "Randy" Berry 2011-07-04 23:07:13 EDT
Description of problem:

PDF's fail to load in browser window when a PDF link is selected.

Version-Release number of selected component (if applicable):

firefox-3.6.18-1.fc14.i686
mozplugger-1.14.2-1.fc14.1686

How reproducible:
Always

Steps to Reproduce:
1. Load firefox browser
2. Navigate to a page with a PDF download link.
3. Click the PDF link
  
Actual results:
Browser page turns white (blank) then briefly turns black, then white again. PDF is never loaded.

Expected results:
PDF file should load and be viewable from browser window. At least that's the way it has always worked before. Removal of mozplugger at least allows a dialogue box to appear allowing selection to either view PDF with document viewer or download the PDF. I've tried this on 2 machines both running the same versions of firefox and mozplugger. 

Additional info:
For what it's worth the same happens on Spot's firefox4 installed on the same machine. (firefox-4.0.1-2.fc14.1686)
Comment 1 Randall "Randy" Berry 2011-07-05 01:50:38 EDT
Also filed a bug upstream, https://www.mozdev.org/bugs/show_bug.cgi?id=23696
Comment 2 Randall "Randy" Berry 2011-07-05 02:17:46 EDT
I tried a build of the current upstream source (1.14.3) and this bug still persists with the same results.
Comment 3 Randall "Randy" Berry 2011-07-05 17:46:27 EDT
Ah! More info reveals itself.. It's not mozplugger at all it's nspluginwrapper! I downgraded nspluginwrapper.i686 0:1.3.2-1.fc14 to nspluginwrapper-1.3.0-14.fc14.i686 from koji and the problem went away. PDF's now embed in browser window.
 
Sorry for the noise, I'll file a bug with nspluginwrapper.

Note You need to log in before you can comment on or make changes to this bug.