Bug 71892 - gdmphotosetup file browsing window never gets focus
gdmphotosetup file browsing window never gets focus
Status: CLOSED RAWHIDE
Product: Red Hat Linux Beta
Classification: Retired
Component: gdm (Show other bugs)
beta5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Mike McLean
:
Depends On:
Blocks: 67218
  Show dependency treegraph
 
Reported: 2002-08-19 21:05 EDT by Paul Iadonisi
Modified: 2007-04-18 12:45 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-28 17:01:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix the modality problem with gdmphotosetup (1.09 KB, patch)
2002-08-26 19:59 EDT, George Lebl
no flags Details | Diff

  None (edit)
Description Paul Iadonisi 2002-08-19 21:05:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.3 (X11; Linux i686; U;) Gecko/20020523

Description of problem:
After enabling the gdm face browser in (null), I launched the gdmphotosetup
(Preferences->Login Photo) and tried to browse the filesystem by clicking the
Browse button.  The browsing window launches but never gets focus, making it
unsuable.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install (null)
2.Enable the gdm face browser
  System Settings->Login Screen->Standard Greeter and click on "Show choosable
user images (face browser)"
3.Lauch Preferences->Login Photo (gdmphotosetup)
4.Click on the Browse button
5.Try browsing in the Browse window
	

Actual Results:  The browse window never gets focus, so it's not possible to
browse the filesystem to select a gdm photo.

Expected Results:  The browse window should get focus and allow the user to
browse the filesystem to select a gdm photo.

Additional info:

Tried in:
  Gnome/metacity
  Gnome/sawfish
  KDE/kwm

all failed as described above.
Comment 1 Havoc Pennington 2002-08-20 18:49:01 EDT
Ah, it appears that the browse file selector is shadowed by some modal window.
Comment 2 George Lebl 2002-08-21 02:37:14 EDT
This is fixed in 2.4.0.8 (among many other cool things, coolest being the
girlfreidn approved icon of course:)
Comment 3 Elliot Lee 2002-08-26 14:45:17 EDT
This will have to wait - upgrading to gdm 2.4.0.9 is a bit scary right now.
Comment 4 George Lebl 2002-08-26 19:56:54 EDT
You could just take the gdmphotosetup.c from .9 or .8 (it's the same) ... The
diff is not too big, want me to make a patch?
Comment 5 George Lebl 2002-08-26 19:58:53 EDT
hmmm, too easy to make a patch, attaching
Comment 6 George Lebl 2002-08-26 19:59:44 EDT
Created attachment 73244 [details]
Patch to fix the modality problem with gdmphotosetup
Comment 7 Havoc Pennington 2002-08-28 17:01:33 EDT
patch applied 2.4.0.7-7, thanks
Comment 8 Jay Turner 2002-09-03 15:58:03 EDT
Fix confirmed with gdm-2.4.0.7-10.

Note You need to log in before you can comment on or make changes to this bug.