Bug 71914 - Inconsistent behavior with pam_timestamp
Summary: Inconsistent behavior with pam_timestamp
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-httpd   
(Show other bugs)
Version: null
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-20 06:01 UTC by Dax Kelson
Modified: 2015-03-05 01:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-20 08:08:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dax Kelson 2002-08-20 06:01:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3; Linux)

Description of problem:
When logging to the GNOME2 desktop:

Desktop -> Start Here -> Server Settings

The following redhat-config apps exist:

Domain Name Service
HTTP Server
NFS Server
Services

All of them EXCEPT for redhat-config-httpd uses pam_timestamp. This is inconsistent,unexpected and confusing behavior for the "newbie" Linux sysadmin who is most likely to be using these GUI configuration apps.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. less /etc/pam.d/redhat-config-httpd
2. Notice how pam_timestamp is NOT used
3. Compare to the other redhat-config apps
	

Actual Results:  n/a

Expected Results:  n/a

Additional info:

There are 22 /etc/pam.d/redhat-config-* files.

It looks like ALL of them use pam_timestamp except for:

redhat-config-printer
redhat-config-printer-tui
redhat-config-httpd

Comment 1 Tim Waugh 2002-08-20 08:08:40 UTC
TUI apps must not use pam_timestamp, which takes redhat-config-printer-tui out 
of your list.  Also, the command 'redhat-config-printer' may end up invoking 
the TUI app, and so it also intentionally doesn't use pam_timestamp. 
 
(The menus run 'redhat-config-printer-gui', which *does* use pam_timestamp.) 
 
So this bug report just concerns redhat-config-httpd.

Comment 2 Phil Knirsch 2002-08-20 09:50:51 UTC
OK, fixed in CVS. Somehow this didn't make it into the fixes i made recently to
redhat-config-httpd.

Next build will include the fix.

Read ya, Phil


Note You need to log in before you can comment on or make changes to this bug.