Bug 71924 - UTF-8 characters displayed wrong in gdm panel
UTF-8 characters displayed wrong in gdm panel
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: gdm (Show other bugs)
null
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Mike McLean
:
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-08-20 05:17 EDT by Markku Kolkka
Modified: 2007-04-18 12:45 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-21 06:55:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Markku Kolkka 2002-08-20 05:17:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020809

Description of problem:
My system is set up to use Finnish language (LANG=fi_FI.UTF-8). On the gdm
graphical greeter the third panel item has instead of "d" (LATIN SMALL LETTER A
WITH DIAERESIS) a pair of characters "C¤" (LATIN CAPITAL LETTER A WITH
TILDE + CURRENCY SIGN). This is a result of displaying the two bytes of UTF-8
encoded character as two 8-bit Latin-1 characters.



Version-Release number of selected component (if applicable):
gdm-2.4.0.7-3

How reproducible:
Always

Steps to Reproduce:
1.Install (null) with Finnish as default language
2.boot to runlevel 5
3.
	

Actual Results:  The third gdm greeter button is "JC¤rjestelmC¤"

Expected Results:  The text should be "Jdrjestelmd"

Additional info:
Comment 1 Markku Kolkka 2002-08-20 05:18:32 EDT
Bugzilla seems to mangle any 8-bit characters in report.
Comment 2 Mattias Dahlberg 2002-08-20 09:39:23 EDT
Yes, this happens with Swedish as well. The word for "Language" is rendered 
wrongly. There's also a problem with the translation for "Root password" in the 
System-Settings. The UTF-8-characters seems to be displayed as ISO 8859-1. (But 
not all of them.)
Comment 3 Havoc Pennington 2002-08-20 10:34:52 EDT
Can you try with redhat-artwork 0.37 or 0.38 if you haven't?
Comment 4 Markku Kolkka 2002-08-20 12:21:18 EDT
redhat-artwork 0.38-1 from Rawhide fixes the problem (at least in Finnish)
Comment 5 Mattias Dahlberg 2002-08-21 04:52:12 EDT
redhat-artwork 0.38 fixed the gdm fonts for Swedish as well. But the UTF-8 
character in the translation for "Root Password" in System-Settings is still 
displayed wrongly, but perhaps I should open a new bug report for that?
Comment 6 Mattias Dahlberg 2002-08-21 06:55:51 EDT
The "Root Password bug" was already reported:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=71825

All is fine. :)

Note You need to log in before you can comment on or make changes to this bug.