Bug 719513 - [ml_IN][libreoffice] perfer Meera over AnjaliOldLipi for default document font
[ml_IN][libreoffice] perfer Meera over AnjaliOldLipi for default document font
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
15
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-07 02:02 EDT by Satyabrata Maitra
Modified: 2011-10-03 10:58 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-03 07:20:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 32953 None None None Never

  None (edit)
Description Satyabrata Maitra 2011-07-07 02:02:09 EDT
Description of problem:
In Fedora 15 Release version, the default font for oowriter, oocalc, is appearing as "AnjaliOldLipi" which is wrong. It should appear with "Meera" Font instead, for Malayalam Locale (ml_IN).

Version-Release number of selected component (if applicable):
libreoffice-core-3.3.2.2-7.fc15

How reproducible:
Always.

Steps to Reproduce:
1. Install Fedora-15 with Malayalam language
2. Open oowriter or oocalc
3. Observe the Default Font appearing.
  
Actual results:
The default font is showing "AnjaliOldLipi".

Expected results:
It should appear with "Meera" font by default.

Additional info:
Comment 1 Caolan McNamara 2011-07-07 03:59:15 EDT
AnjaliOldLipi was the selection based on:
https://bugs.freedesktop.org/show_bug.cgi?id=32953

"Meera - almost good as AnjaliOldLipi, but totally missing  0D7A, 0D7B, 
        0D7C, 0D7D, 0D7E"
Comment 2 Caolan McNamara 2011-07-07 04:02:50 EDT
So, is there a better justification to sort Meera before AnjaliOldLipi for Malayalam as the default document font for Malayalam ? Or is the above convincing for AnjaliOldLipi.
Comment 3 Satyabrata Maitra 2011-07-07 05:04:50 EDT
Pravin and Ani

Can you please justify it and reply? As per the fc-match The default font for malayalam Desktop is meera.

(In reply to comment #2)
> So, is there a better justification to sort Meera before AnjaliOldLipi for
> Malayalam as the default document font for Malayalam ? Or is the above
> convincing for AnjaliOldLipi.
Comment 4 Ani Peter 2011-07-07 05:43:32 EDT
libreoffice-core-3.3.2.2-7.fc15 has already changed the default Malayalam font to AnjaliOldLipi from Meera. Am forwarding the bug to community for further discussions.

Thanks
Ani
Comment 5 Caolan McNamara 2011-10-03 07:20:31 EDT
I can't personally judge which is the better default. Upstream I accepted the argument that AnjaliOldLipi was better than Meera because it had 0D7A, 0D7B, 0D7C, 0D7D, 0D7E.

Feel free to reopen this if you think that was a bad decision or if there's a alternative consensus about the best font for ml and I'll fix it upstream as well.

Note You need to log in before you can comment on or make changes to this bug.