Bug 71972 - mod_ssl fails after rpm updates of apache on RH 6.2jp
mod_ssl fails after rpm updates of apache on RH 6.2jp
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: apache (Show other bugs)
6.2J
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-20 11:01 EDT by James McDermott
Modified: 2014-08-24 20:55 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-21 06:51:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James McDermott 2002-08-20 11:01:26 EDT
Hardware Environment: i386

Software Environment: Red Hat 6.2jp with latest Red Hat official patches.


Steps to Reproduce:
1. Install Red Hat 6.2jp
2. Install the latest patches from Red Hat (specifically 
apache-1.3.22-5.6.i386.rpm, openssl-0.9.5a-7.6.x.i386.rpm)
3.  Attempt to use mod_ssl enabled functions in Apache.

Actual Results:
The mod_ssl Apache module does not seem to work.  Attempts to browse to a https 
page on the server results in a segmentation fault in the apache log:
 child pid XXXX exit signal Segmentation fault (11)

Expected Results:
This problem does not occur with the base levels of 6.2jp installed.  There 
appears to be a incompatibility between the apache, openssl and mod_ssl versions 
when the rpm updates are applied.  The customer needs an official mod_ssl rpm 
created that will work properly with apache and openssl rpm updates in Red Hat 
6.2jp.
Comment 1 Joe Orton 2004-09-21 06:51:52 EDT
Thanks for the report.  This is a mass bug update; since this release
of Red Hat Linux is no longer supported, please either:

a) try and reproduce the bug with a supported version of Red Hat
Enterprise Linux or Fedora Core, and re-open this bug as appropriate
after changing the Product field, or,

b) if relevant, try and reproduce this bug using the current version
of the upstream package, and report the bug upstream.

Note You need to log in before you can comment on or make changes to this bug.