Bug 71982 - Can't compile newest stable kernel 2.4.19 or newer from kernel.org with RedHat tools
Summary: Can't compile newest stable kernel 2.4.19 or newer from kernel.org with RedHa...
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
high
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-20 15:45 UTC by jar
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-02 20:56:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description jar 2002-08-20 15:45:21 UTC
Description of Problem:

Impossible to compile the newest stable kernel 2.4.19 or newer from kernel.org with RedHat 7.3.
I have 100% up to date RedHat 7.3 system and I have no succes to compile e.g. the latest
stable kernel 2.4.19 from kernel.org. I get many "Segmentation faults" when compiling the
kernel and/or the modules ! Something wrong in RedHat gnu C compiling tools ?

Version-Release number of selected component (if applicable):

gcc 2.96-112

How Reproducible:

Just compile: make config-->make dep-->make clean-->make modules

Steps to Reproduce:
1. 
2. 
3. 

Actual Results:

-DMODULE -DMODVERSIONS -include
/usr/src/linux-2.4.19/include/linux/modversions.h  -nostdinc -I
/usr/lib/gcc-lib/i386-redhat-linux/2.96/include -DKBUILD_BASENAME=epia 
-c -o epia.o epia.c
In file included from epia.c:26:
/usr/src/linux-2.4.19/include/linux/wait.h: In function
`waitqueue_active':
/usr/src/linux-2.4.19/include/linux/wait.h:191: Internal error:
Segmentation fault.
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[3]: *** [epia.o] Error 2
make[3]: Leaving directory `/usr/src/linux-2.4.19/drivers/block/paride'
make[2]: *** [_modsubdir_paride] Error 2
make[2]: Leaving directory `/usr/src/linux-2.4.19/drivers/block'
make[1]: *** [_modsubdir_block] Error 2
make[1]: Leaving directory `/usr/src/linux-2.4.19/drivers'
make: *** [_mod_drivers] Error 2
***************************************************************************************
make[3]: Entering directory `/usr/src/linux-2.4.19/drivers/isdn/pcbit'
gcc -D__KERNEL__ -I/usr/src/linux-2.4.19/include -Wall
-Wstrict-prototypes -Wno-trigraphs -O2 -fno-strict-aliasing -fno-common
-fomit-frame-pointer -pipe -mpreferred-stack-boundary=2 -march=i586
-DMODULE -DMODVERSIONS -include
/usr/src/linux-2.4.19/include/linux/modversions.h  -nostdinc -I
/usr/lib/gcc-lib/i386-redhat-linux/2.96/include
-DKBUILD_BASENAME=module  -c -o module.o module.c
In file included from /usr/src/linux-2.4.19/include/linux/skbuff.h:26,
                 from module.c:18:
/usr/src/linux-2.4.19/include/linux/mm.h: In function `pmd_alloc':
/usr/src/linux-2.4.19/include/linux/mm.h:505: Internal error:
Segmentation fault.
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[3]: *** [module.o] Error 2
make[3]: Leaving directory `/usr/src/linux-2.4.19/drivers/isdn/pcbit'
make[2]: *** [_modsubdir_pcbit] Error 2
make[2]: Leaving directory `/usr/src/linux-2.4.19/drivers/isdn'
make[1]: *** [_modsubdir_isdn] Error 2
make[1]: Leaving directory `/usr/src/linux-2.4.19/drivers'
make: *** [_mod_drivers] Error 2
****************************************************************************
gcc -D__KERNEL__ -I/usr/src/linux-2.4.19/include -Wall
-Wstrict-prototypes -Wno-trigraphs -O2 -fno-strict-aliasing -fno-common
-fomit-frame-pointer -pipe -mpreferred-stack-boundary=2 -march=i586
-DMODULE -DMODVERSIONS -include
/usr/src/linux-2.4.19/include/linux/modversions.h  -nostdinc -I
/usr/lib/gcc-lib/i386-redhat-linux/2.96/include
-DKBUILD_BASENAME=AM53C974  -c -o AM53C974.o AM53C974.c
AM53C974.c: In function `AM53C974_init':
AM53C974.c:765: Internal error: Segmentation fault.
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[2]: *** [AM53C974.o] Error 2
make[2]: Leaving directory `/usr/src/linux-2.4.19/drivers/scsi'
make[1]: *** [_modsubdir_scsi] Error 2
make[1]: Leaving directory `/usr/src/linux-2.4.19/drivers'
make: *** [_mod_drivers] Error 2
*********************************************************************************
gcc -D__KERNEL__ -I/usr/src/linux-2.4.19/include -Wall
-Wstrict-prototypes -Wno-trigraphs -O2 -fno-strict-aliasing -fno-common
-fomit-frame-pointer -pipe -mpreferred-stack-boundary=2 -march=i586
-DMODULE -DMODVERSIONS -include
/usr/src/linux-2.4.19/include/linux/modversions.h  -nostdinc -I
/usr/lib/gcc-lib/i386-redhat-linux/2.96/include
-DKBUILD_BASENAME=ip6_tables  -DEXPORT_SYMTAB -c ip6_tables.c
ip6_tables.c: In function `print_name':
ip6_tables.c:1757: Internal error: Segmentation fault.
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[2]: *** [ip6_tables.o] Error 1
make[2]: Leaving directory `/usr/src/linux-2.4.19/net/ipv6/netfilter'
make[1]: *** [_modsubdir_ipv6/netfilter] Error 2
make[1]: Leaving directory `/usr/src/linux-2.4.19/net'
make: *** [_mod_net] Error 2
Expected Results:

Additional Information:

Comment 1 Alan Cox 2002-12-15 22:41:11 UTC
Seem to be errors at random points - hardware generally. gcc shows this up
because it stresses the memory subsystem a lot. Check the memory with memtest86


Comment 2 Jakub Jelinek 2004-10-02 20:56:05 UTC
GCC 2.96-RH is too old now and it really looks like hardware issues.
Closing.


Note You need to log in before you can comment on or make changes to this bug.