Bug 71996 - rawhide-release never gets properly installed
rawhide-release never gets properly installed
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-20 13:00 EDT by rudi
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-20 13:00:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description rudi 2002-08-20 13:00:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1b) Gecko/20020817

Description of problem:
There is something wrong with all the rawhide-release packages in the
past few weeks. I doubt it's due to rawhide-release itself; I rather
suspect it's something to do with RPM.

Version-Release number of selected component (if applicable):
4.1.x

How reproducible:
Always

Steps to Reproduce:
# rpm -q rawhide-release
package rawhide-release is not installed
# rpm -Uvh rawhide-release-20020820-1.noarch.rpm 
Preparing...                ########################################### [100%]
   1:rawhide-release        ########################################### [100%]
error: rpmdb: skipping h#     683 
# rpm -q rawhide-release
# rpm --rebuilddb
# rpm -q rawhide-release
package rawhide-release is not installed


Actual Results:
rawhide-release is not correctly added to the RPM database and an
error message is output. The file /etc/redhat-release gets correctly
written out to disk, but there's no trace of that in the RPM database.
The dependencies for autofs and initscripts will thus break. It
doesn't look like anything is getting corrupted, but it doesn't inspire
much trust either. The behaviour in the steps above is quite puzzling,
too: take a close look at what rpm -q returns.

Additional info:

I have been seeing this in recent weeks on four different systems.
All of them more of less always up-to-date with the most recent
Raw Hide packages. One of them was switched from RH 7.1 to Raw Hide
just last night and it exhibits the very same symptoms. This seems to
have started some time after the switch to RPM 4.1.
Comment 1 Jeff Johnson 2002-08-21 20:25:42 EDT
Fixed in rpm-4.1-0.86 (when built).

Note You need to log in before you can comment on or make changes to this bug.