Bug 72022 - Company Name field not required, but should be
Company Name field not required, but should be
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site (Show other bugs)
RHN Stable
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Lisa Justice
Fanny Augustin
https://rhn.redhat.com/newlogin/creat...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-20 15:30 EDT by Lisa Justice
Modified: 2007-04-18 12:45 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-17 15:15:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lisa Justice 2002-08-20 15:30:21 EDT
Description of Problem:
Company Name field on the "Create a Corporate Account" page is not a required
field.  This *should* be a required field and should be indicated as such with
an "*" asterisk - similar to First Name and Last Name fields.

We are running into issues on this end with OAI due to the following:

 PIN_WEB_CUSTOMER_ID: 911331
    PIN_CUSTOMER_NAME: RICHARD CRANDALL
    PIN_COMPANY_NAME: null
    PIN_CUSTOMER_TYPE: B
) was not written to the database.
java.sql.SQLException: ORA-01400: cannot insert NULL into
("AR"."RA_CUSTOMERS_INTERFACE_ALL"."CUSTOMER_NAME")
ORA-06512: at "APPS.XXRH_OAI", line 1547
ORA-06512: at "APPS.XXRH_OAI_CUSTOMER", line 349

So....we've had to create a work around to get these particular types of entries
into Oracle.  


How Reproducible:
Very

Steps to Reproduce:
1. Go to link listed above.
2. Enter all required information (fields with asterisk).  Do not enter anything
for the Company Name field.
3. Hit "Create Login"

Actual Results:
Completes login creation with completed Company Name field.  Customer name in
Oracle ends up being "Valued Customer".  This will create many duplicate entries
in Oracle.  Need to clean up before upgrade to 11i.

Expected Results:
Should be a required field.  Should not complete login creation without it.
Comment 1 Robin Norwood 2003-02-04 14:08:35 EST
Changes for the bug are in head, and aligned to the 2/19/03 release.
Comment 2 Josef Komenda 2003-02-17 13:23:48 EST
Looks good on the RHN side, but www still allows corporate account creation with
a blank field. Do we care?
Comment 3 Josef Komenda 2003-02-17 13:39:32 EST
Over to Lisa to adjudicate. 
Comment 4 Lisa Justice 2003-02-17 14:24:07 EST
Looks great on webdev (hope that's where I was supposed to test).  Just
double-checked www as well.....interesting.  I think it should be handled the
same on www, but I can work with the web guys to get that done.  You can close
this bug if you like....(not sure if you guys keep track of who closes/resolves,
so I'll let you guys take credit)

Thanks,
LJH
Comment 5 Josef Komenda 2003-02-17 15:15:58 EST
Works on dev and QA, closing.

Note You need to log in before you can comment on or make changes to this bug.