Bug 720352 - [abrt] ibus-1.3.9-4.fc14: gdk_drawable_get_colormap@plt: Process /usr/bin/python was killed by signal 11 (SIGSEGV)
[abrt] ibus-1.3.9-4.fc14: gdk_drawable_get_colormap@plt: Process /usr/bin/pyt...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
14
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
abrt_hash:5e886e1d6511cfaa6410906e002...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-11 09:47 EDT by Flos Lonicerae
Modified: 2011-07-19 21:14 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-19 21:14:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (90.56 KB, text/plain)
2011-07-11 09:47 EDT, Flos Lonicerae
no flags Details

  None (edit)
Description Flos Lonicerae 2011-07-11 09:47:14 EDT
abrt version: 1.1.18
architecture: i686
Attached file: backtrace, 92738 bytes
cmdline: /usr/bin/python /usr/share/ibus/ui/gtk/main.py
component: ibus
Attached file: coredump, 10690560 bytes
crash_function: gdk_drawable_get_colormap@plt
executable: /usr/bin/python
kernel: 2.6.35.13-91.fc14.i686
package: ibus-1.3.9-4.fc14
rating: 4
reason: Process /usr/bin/python was killed by signal 11 (SIGSEGV)
release: Fedora release 14 (Laughlin)
time: 1310391401
uid: 500

How to reproduce
-----
1. open chromium
2. change ibus input method to pinyin
3. abrtd popup window shows


ibus.i686                                                1.3.9-4.fc14
ibus-pinyin.i686                                            1.3.11-1.fc14
chromium.i686                                   12.0.742.91-1.fc14
Comment 1 Flos Lonicerae 2011-07-11 09:47:41 EDT
Created attachment 512221 [details]
File: backtrace
Comment 2 fujiwara 2011-07-12 22:46:45 EDT
Are you still able to reproduce your problem?
I don't see any problems.

From your backtrace, it seems the colormaps doesn't work in your system.
It may be good to check your colors with xorg.conf .
Comment 3 Flos Lonicerae 2011-07-15 08:58:20 EDT
no, i just run into it once. my xorg.conf is here:


# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildmeister@builder63)  Wed Sep 29 10:20:38 PDT 2010

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
    FontPath        "/usr/share/fonts/default/Type1"
EndSection

Section "ServerFlags"
    Option         "Xinerama" "0"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from data in "/etc/sysconfig/keyboard"
    Identifier     "Keyboard0"
    Driver         "keyboard"
    Option         "XkbLayout" "us"
    Option         "XkbModel" "pc105"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "ViewSonic VE710b-2"
    HorizSync       30.0 - 82.0
    VertRefresh     50.0 - 85.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Videocard0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce FX 5700LE"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Videocard0"
    Monitor        "Monitor0"
    DefaultDepth    16
    Option         "TwinView" "0"
    Option         "TwinViewXineramaInfoOrder" "CRT-0"
    Option         "metamodes" "1024x768_60 +0+0; 1024x768 +0+0; 800x600 +0+0; 720x400 +0+0; 640x480 +0+0; 640x400 +0+0; 640x350 +0+0"
    SubSection     "Display"
        Depth       16
    EndSubSection
EndSection
Comment 4 fujiwara 2011-07-19 00:39:24 EDT
I guess your colormap was exhausted eventually.
Unfortunately the xorg.conf doesn't help me to find the root cause.
I'd like to close this bug if you no longer encounter your problem.
Comment 5 Flos Lonicerae 2011-07-19 06:57:00 EDT
ok. if it can be reproduced, i will reopen it.
Comment 6 fujiwara 2011-07-19 21:14:33 EDT
Thanks.

Note You need to log in before you can comment on or make changes to this bug.