Bug 720460 - Brother HL5250DN falsely reports out of toner and not connected
Brother HL5250DN falsely reports out of toner and not connected
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
15
i686 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-11 13:02 EDT by Jim Haynes
Modified: 2011-07-22 12:39 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-20 11:45:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
output from printing troubleshooter (99.12 KB, text/plain)
2011-07-12 10:54 EDT, Jim Haynes
no flags Details
Output from troubleshoot run for MFC-J6710DW machine (70.74 KB, text/plain)
2011-07-12 10:58 EDT, Jim Haynes
no flags Details
requested results under F14 (1.71 KB, application/octet-stream)
2011-07-20 10:50 EDT, Jim Haynes
no flags Details
Results of the same snmp commands under F15 (1.79 KB, application/octet-stream)
2011-07-20 11:28 EDT, Jim Haynes
no flags Details
Error log see previous message (18.58 KB, application/octet-stream)
2011-07-21 12:32 EDT, Jim Haynes
no flags Details

  None (edit)
Description Jim Haynes 2011-07-11 13:02:55 EDT
Description of problem:
I just got my printer working under F15, using system-config-printer
I had to install foomatic-db to get it to install.  Now when I print
it falsely reports the printer is out of toner.  It doesn't do this
in F14.

Version-Release number of selected component (if applicable):


How reproducible:
Every time I print.

Steps to Reproduce:
1.echo 'foo' | lpr  (or anything else to make printer work)
2.
3.
  
Actual results:
Black windows pop up in the upper right corner of the screen, first
reporting the print job sent to the printer, then reporting printer is
not connected, then reporting printer is out of toner.  Then it prints
just fine.

Expected results:

No false messages
Additional info:
Comment 1 Tim Waugh 2011-07-12 03:40:53 EDT
Please run the printing troubleshooter and attach the resulting troubleshoot.txt, which contains information about your printing configuration.

https://fedoraproject.org/wiki/Printing/Debugging#Printing_troubleshooter
Comment 2 Jim Haynes 2011-07-12 10:54:02 EDT
Created attachment 512447 [details]
output from printing troubleshooter
Comment 3 Jim Haynes 2011-07-12 10:58:05 EDT
Created attachment 512449 [details]
Output from troubleshoot run for MFC-J6710DW machine
Comment 4 Jim Haynes 2011-07-12 11:01:40 EDT
Oh, guess my comments got cleared when I did the attachments.
The first attachment is from the HL5250DN  printer test run.  It does print
correctly, in spite of the false reports of not connected and out of toner.

The second attachment is from the Brother MFC-J6710DW machine.  I installed
the printer and scanner drivers from the Brother web site.  It works OK as a
scanner.  In trying to print it gives false disconnected and out of ink
messages like the other printer does.  Then it never prints - keeps displaying
that it is receiving data, but after a few minutes of this I decided it was
not going to print and killed the print job.  It prints fine under F14.
Comment 5 Tim Waugh 2011-07-20 07:59:03 EDT
Please show the output of these commands:

snmpwalk -Os -c public -v 1 192.168.2.10 1.3.6.1.2.1.43.11.1.1.9
snmpwalk -Os -c public -v 1 192.168.2.10 1.3.6.1.2.1.43.11.1.1.8

snmpwalk -Os -c public -v 1 192.168.2.12 1.3.6.1.2.1.43.11.1.1.9
snmpwalk -Os -c public -v 1 192.168.2.12 1.3.6.1.2.1.43.11.1.1.8

(snmpwalk is in the net-snmp-utils package)

Note that the toner/marker level reporting is not related to being able to print.  The reason the second log shows that it is unable to print is here:

D [12/Jul/2011:09:45:31 -0500] [Job 9] /usr/lib/cups/filter/brlpdwrappermfcj6710dw: line 118: /opt/brother/Printers/mfcj6710dw/cupswrapper/brcupsconfpt1: Permission denied
D [12/Jul/2011:09:45:31 -0500] [Job 9] /usr/lib/cups/filter/brlpdwrappermfcj6710dw: line 125: /opt/brother/Printers/mfcj6710dw/lpd/filtermfcj6710dw: Permission denied
Comment 6 Jim Haynes 2011-07-20 10:49:18 EDT
Here's output from those commands under F14.  I will try again in a little while
under F15.
Comment 7 Jim Haynes 2011-07-20 10:50:49 EDT
Created attachment 514022 [details]
requested results under F14
Comment 8 Jim Haynes 2011-07-20 10:51:55 EDT
For the MFC-J6710DW should I try deleting it and adding it again?  That
process always seems squirrelly.
Comment 9 Jim Haynes 2011-07-20 11:28:42 EDT
Created attachment 514038 [details]
Results of the same snmp commands under F15
Comment 10 Tim Waugh 2011-07-20 11:45:57 EDT
Those commands are asking the printer questions about its supply levels and capacity.

Those answers are:

192.168.2.10:
level  capacity
    0        -2
   -3        -2
17409     25000

192.168.2.12:
level  capacity
   -3       500
   -3       400
   -3       400
   -3       400

The 192.168.2.12 printer is definitely telling us it's out of toner (but -3 is
a weird value for the level); the other printer had previously been saying
something like 0/1, judging by the debug output from comment #2.

The issue is with the printers.  Perhaps there are firmware updates you can apply that might fix supply level reporting?

As for the permissions problem: it looks like your driver is not correctly
installed.
Comment 11 Jim Haynes 2011-07-20 13:00:04 EDT
Now concerning those two permission denied messages, I looked at the files
in question and both are publicly executable and did not give any error when
I hand-executed them.  I did get, trying to send some text into that last one,
a message that a2ps was not found.

I started the printer troubleshooter from system-config-printer and in the
course of things I got the following error message

Traceback:
File "/usr/share/system-config-printer/troubleshoot/__init__.py", line 297, in _display
    result = question.display ()
File "/usr/share/system-config-printer/troubleshoot/PrinterStateReasons.py", line 57, in display
    ppdcache = ppdcache.PPDCache ()
UnboundLocalError: local variable 'ppdcache' referenced before assignment

I tried printing a test page and, as before, the printer indicates it is
receiving data, but this goes on for quite a while and it never prints.
Eventually the printer went back to sleep.  
I will send the troubleshoot.txt.  I see that it says
/var/spool/cups/tmp (Permission denied)  /var/spool/cups is
drwx--x---. 3 root lp 4096 Jul 20 11:51 /var/spool/cups
/var/spool/cups/tmp is 
drwxrwx--T. 2 root lp 4096 Jul 20 10:46 tmp
Comment 12 Tim Waugh 2011-07-21 04:39:44 EDT
The files in question are:

/opt/brother/Printers/mfcj6710dw/cupswrapper/brcupsconfpt1
/opt/brother/Printers/mfcj6710dw/lpd/filtermfcj6710dw

referenced from:

/usr/lib/cups/filter/brlpdwrappermfcj6710dw: line 118
/usr/lib/cups/filter/brlpdwrappermfcj6710dw: line 125

Did you look at the /usr/lib files, or the /opt files?

The /var/spool/cups/tmp missing message can be ignored: it is a result of running 'rpm -V' as a non-root user and is to be expected.
Comment 13 Jim Haynes 2011-07-21 12:27:46 EDT
I went to the files in /opt   they are publicly readable/executable

The /usr/lib/cups/filter/brlpdwrappermfcj6710dw is also publicly read/execute

I removed and reinstalled the printer, using system-config-printer, with
no change.

Running system-config-printer gets this

(system-config-printer.py:1760): GVFS-RemoteVolumeMonitor-WARNING **: cannot connect to the session bus: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(system-config-printer.py:1760): GVFS-RemoteVolumeMonitor-WARNING **: cannot connect to the session bus: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(system-config-printer.py:1760): GVFS-RemoteVolumeMonitor-WARNING **: cannot connect to the session bus: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

when started up.

Both printers show an exclamation point in a yellow triangle in the
Printing-localhost window  The HL-5250DN printer also shows a green
check mark.

I double clicked on the MFC-J6710DW icon and it brought up a
Printer Properties window saying
Description: Brother MFC-J6710DW
Location: BigBrother
Device URI: lpd://192.168.2.12/PASSTHRU
Make and Model: Brother MFC-J6710DW CUPS
Printer State: Idle

under Policies tab, Enable and Accepting jobs are checked

under Access Control, Allow printing for everyone except these users:

under Printer Options, Media Size: Letter
                       Two-Sided: Off
                       Media Type: Plain Paper
                       Slow Drying Paper: Off
                       Color/Grayscale: Color
                       Paper Source: Auto-Select
                       Mirror Printing: Off
                       Paper Thickness: Regular
                       Bi-Directional Printing: On
                       Advanced Duplex Settings: Normal
                       change Data Transfer Mode: Recommended Setting
                       Color Settings
                       Color Mode: Natural
                       Color Settings (Advanced)
                       Halftone Pattern: Diffusion
                       Color Enhancement: Off
                       Brightness: 0
                       Contrast: 0
                       Red: 0
                       Green: 0
                       Blue: 0

under Job Options
                       Common Options
                       Copies 1
                       Orientation: Automatic Rotation
                       Pages per side: 1
                       (and a lot of other stuff that seems normal)

under Ink/Toner levels
                      Clear drop icons for all the colors
                      Status Messages
                      ! Printer "Brother-MFC-J6710DW' has no link left

I punched "Refresh" on that screen and got a black popup in the upper right
corner of the screen saying the printer is disconnected and a window saying
Maintenance command submitted as job 12 and I clicked OK on that.

On the printer itself the FAX button is lit up, but I think that is normal
since there is not a print button.
Comment 14 Jim Haynes 2011-07-21 12:30:46 EDT
Continuing from what I just reported, the access log shows
localhost - - [21/Jul/2011:10:54:06 -0500] "POST / HTTP/1.1" 200 362 Create-Prin
ter-Subscription successful-ok
localhost - - [21/Jul/2011:11:12:09 -0500] "POST / HTTP/1.1" 200 252 Create-Prin
ter-Subscription successful-ok
localhost - - [21/Jul/2011:11:24:37 -0500] "POST /printers/Brother-MFC-J6710DW H
TTP/1.1" 200 262 Print-Job successful-ok
localhost - - [21/Jul/2011:11:25:51 -0500] "POST /printers/Brother-MFC-J6710DW H
TTP/1.1" 200 262 Print-Job successful-ok
localhost - - [21/Jul/2011:11:26:54 -0500] "POST / HTTP/1.1" 200 152 Cancel-Subs
cription successful-ok

and I will attach the error long in the next message
Comment 15 Jim Haynes 2011-07-21 12:32:26 EDT
Created attachment 514228 [details]
Error log see previous message
Comment 16 Jim Haynes 2011-07-21 13:00:40 EDT
Now repeating the previous experiments under F14, where the printer does work.

Starting system-config-printer
(system-config-printer.py:2244): GVFS-RemoteVolumeMonitor-WARNING **: cannot connect to the session bus: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(system-config-printer.py:2244): GVFS-RemoteVolumeMonitor-WARNING **: cannot connect to the session bus: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(system-config-printer.py:2244): GVFS-RemoteVolumeMonitor-WARNING **: cannot connect to the session bus: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

The Printing - localhost window opens with both printers, the green check on
Brother-HL-5250DN, and no exclamation point in a yellow triangle.

Double clicked on MFCJ6710DW opened a window Printer Properties
Settings
Description: MFCJ6710DW
Location: Here
Device URI: lpd://192.168.2.12/binary_p1
Make and Model:  Brother MFC_J6710DW CUPS
Printer State: Idle

Policies:  Enabled and Accepting Jobs are checked
           Error Policy: Stop Printer
           Operation Policy: Default behavior

Access Control: Allow printing for everyone except these users:

Printer Options (same as they are in F15)
Job Options (same as they are in F15)
Ink/Toner Levels
   clear droplet icons for all, but
   Status Messages
      There are no status messages for this printer
      and when I punched Refresh there was a message about a
      Maintenance command submitted as job 209 and I clicked OK

Then back to Status and I clicked on Print Test Page and a few seconds later
it printed.

there is a zero size page_log

and no error_log

access_log shows
localhost - root [21/Jul/2011:11:47:38 -0500] "POST /printers/MFCJ6710DW HTTP/1.
1" 200 253 Print-Job successful-ok
localhost - root [21/Jul/2011:11:47:50 -0500] "POST /printers/MFCJ6710DW HTTP/1.
1" 200 253 Print-Job successful-ok
localhost - root [21/Jul/2011:11:48:11 -0500] "POST /printers/MFCJ6710DW HTTP/1.
1" 200 253 Print-Job successful-ok
localhost - - [21/Jul/2011:11:48:56 -0500] "POST /printers/MFCJ6710DW HTTP/1.1" 
200 482 Print-Job successful-ok

There seems to be no difference between F14 and F15 in those files in
/opt/brother/Printers nor in the /usr/lib/cups/filter script
Comment 17 Tim Waugh 2011-07-22 04:27:46 EDT
At this stage the problem is with the Brother driver, which we don't ship and which is not open source.  Please contact them to try to determine the problem.  My suspicion is that it is not installed correctly; perhaps the SELinux file contexts are incorrect, or the ownership is wrong, or something like that.
Comment 18 Jim Haynes 2011-07-22 12:39:13 EDT
I've emailed Brother about the false out-of-ink reports.

Changing SELinux from enforcing to permissive allows the
MFC-J6710DW printer to print.  I couldn't find a handy tool
to change the SELinux mode permanently, so altered the /etc/selinux/config
file by hand.

Note You need to log in before you can comment on or make changes to this bug.