This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 720524 - No network (NAT) in guests on a Rawhide (F16) host
No network (NAT) in guests on a Rawhide (F16) host
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Fedora Virtualization Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-11 19:41 EDT by Adam Williamson
Modified: 2011-09-22 16:26 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-22 16:26:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2011-07-11 19:41:27 EDT
I'm running current Rawhide, a pretty clean install - clean installed F15 and updated to Rawhide shortly after - on my desktop. I tried to set up a VM, following the 'normal' process: 'yum groupinstall Virtualization', then use virt-manager's wizard to set up a VM. Normally, networking would work in the guest using the default NAT setup; this is how it's always been for me before, with F15 and F14. But now it doesn't work, the guest gets no working network connection. There is an eth0 interface, but it always fails to get an IPv4 address via DHCP.

I did not do anything unusual to the configuration of virt-manager or libvirt or qemu or anything. I did some troubleshooting via IRC with acathrow, who said he couldn't see anything out of place about the setup. We tested:

* Disabling firewall
* Enabling IPv4 forwarding, which seems to be disabled by default (echo 1 > /proc/sys/net/ipv4/ip_forward )
* Removing virbr0-nic from the bridge
* Loading vhost-net module

none of that seemed to make any difference. Right now I have the vm set up to use virtio for the network interface, but at first I was testing with 'Hypervisor default' - I'm guessing that's rtl8139? - and it didn't work either. I've tried both Windows (XP) and Fedora (current Rawhide XFCE live image) in the guest, so I don't think the guest is to blame.

I can provide remote access to the system if it will help anyone to diagnose the problem.
Comment 1 Adam Williamson 2011-07-11 19:43:32 EDT
oh, the host has selinux set to Permissive, so that shouldn't be interfering.
Comment 2 Fedora Admin XMLRPC Client 2011-09-22 13:49:42 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Fedora Admin XMLRPC Client 2011-09-22 13:52:40 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 4 Fedora Admin XMLRPC Client 2011-09-22 13:57:52 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 5 Adam Williamson 2011-09-22 16:26:52 EDT
This has been fixed for a while, I don't remember what caused it. It may have been the dnsmasq issue.

Note You need to log in before you can comment on or make changes to this bug.