Bug 72053 - kudzu-0.99.64-2: configures CS4236 incorrectly
kudzu-0.99.64-2: configures CS4236 incorrectly
Status: CLOSED DUPLICATE of bug 71820
Product: Red Hat Public Beta
Classification: Retired
Component: kudzu (Show other bugs)
null
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-20 17:53 EDT by Joachim Frieben
Modified: 2014-03-16 22:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-20 17:53:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2002-08-20 17:53:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020809

Description of problem:
During post-install of Red Hat Linux 7.3.94 BETA, "kudzu" correctly detects the
presence of the CS4236 onboard sound chip of my PR440FX based dual Pentium Pro
workstation. At least, that's what it says. However, after configuring the
device, the resulting "modules.conf" file is not set up properly, and hence
sound is not working at all.

Version-Release number of selected component (if applicable):
0.99.64-2

How reproducible:
Always

Steps to Reproduce:
1. Install Red Hat Linux 7.3.94 BETA.
2. "kudzu" detects CS4236 sound device.
3. Enable GNOME sound server.	

Actual Results:  Sound does not work.

Expected Results:  Sound should be up and running.

Additional info:

The conten of the "modules.conf" file is obviously wrong. The one written by
"kudzu" reads:

alias parport_lowlevel parport_pc
alias eth0 eepro100
alias scsi_hostadapter aic7xxx
alias usb-controller usb-uhci
alias sound-slot-2 ad1848
post-install sound-slot-2 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1
|| :
pre-remove sound-slot-2 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :

After installing and executing "sndconfig-0.68-4", sound is working properly.
The new "modules.conf" file reads:

alias parport_lowlevel parport_pc
alias eth0 eepro100
alias scsi_hostadapter aic7xxx
alias usb-controller usb-uhci
alias sound-slot-0 cs4232
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1
|| :
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :
options sound dmabuf=1
alias synth0 opl3
options opl3 io=0x388
options cs4232 isapnp=1

which looks much more like previous ones.
Comment 1 Bill Nottingham 2002-08-21 00:34:47 EDT

*** This bug has been marked as a duplicate of 71820 ***

Note You need to log in before you can comment on or make changes to this bug.