Bug 72062 - HP Business Inkjet 2250 and LPRng
HP Business Inkjet 2250 and LPRng
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: LPRng (Show other bugs)
8.0
All Linux
high Severity high
: ---
: ---
Assigned To: Tim Waugh
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-20 18:56 EDT by louisgtwo
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-08 08:15:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description louisgtwo 2002-08-20 18:56:17 EDT
I have an HP Business Inkjet 2250 on a remote server running LPRng.
When I print from null the printer on server is quiet.

#lpq
Printer: hp2250@localhost (dest hp2250@server)
 Queue: no printable jobs in queue
Printer: hp2250@server
 Queue: no printable jobs in queue
 Status: hp2250: Check_for_missing files: hp2250: no permission to print at
16:56:36.408

I know permissions on server are ok, I'm able to print from 7.3 and samba is
able to print on the server to. Any ideas?

This is my printcap in null

hp2250:\
	:ml#0:\
	:mx#0:\
	:sd=/var/spool/lpd/hp2250:\
	:af=/var/spool/lpd/hp2250/hp2250.acct:\
	:sh:\
	:rm=server:\
	:rp=hp2250:\
	:lpd_bounce=true:\
	:if=/usr/share/printconf/util/mf_wrapper:
Comment 1 Tim Waugh 2002-08-21 02:52:13 EDT
What firewall settings do you have on this machine? 
 
Please run 'tcpdump -n port printer' on the machine while you try to print 
something, and attach the output.  Thanks.
Comment 2 Tim Waugh 2002-08-21 02:52:38 EDT
Also is this a fresh install, or an upgrade from a previously working set-up?
Comment 3 louisgtwo 2002-08-25 14:41:17 EDT
Ok, the problem is the /etc/hosts in null. The way anaconda sets is up:
127.0.0.1         tiger      localhost.localdomain       localhost
192.168.1.1       server

I had to change this to

127.0.0.1         localhost.localdomain       localhost
192.168.1.4       tiger
192.168.1.1       server

This is because server only accepts print jobs from 192.168.1.0/225.225.225.224
network.

This might not be a bug but should anaconda put the real ip in the hosts file?
Comment 4 louisgtwo 2002-08-25 15:00:49 EDT
this is a fresh install of null, for some reason I nerver like upgrading. Oh, if
I didn't mention the server is not running null, only the workstation.
Comment 5 Tim Waugh 2002-08-27 07:48:39 EDT
You probably want: 
 
ACCEPT SERVICE=X REMOTEIP=192.168.1.0/255.255.255.224 
REJECT SERVICE=X NOT SERVER 
 
Otherwise lpd won't accept connections from 127.0.0.1, which isn't what you 
want.
Comment 6 louisgtwo 2002-08-27 14:26:20 EDT
This is what I have for /etc/lpd.perms on print server:

## Permissions

# reject connections from hosts not on HOMENETWORK subnet
ACCEPT SERVICE=X REMOTEIP=192.168.1.0/255.255.255.224
REJECT SERVICE=X NOT SERVER

# do not allow forwarded jobs or requests
REJECT SERVICE=R,C,M FORWARD

# allow root on server to control jobs
ACCEPT SERVICE=C SERVER REMOTEUSER=root

# allow anybody to get server, status, and printcap
ACCEPT SERVICE=C LPC=lpd,status,printcap
# reject all others
REJECT SERVICE=C

# allow same user on originating host to remove a job
ACCEPT SERVICE=M SAMEHOST SAMEUSER

# allow root on server to remove a job
ACCEPT SERVICE=M SERVER REMOTEUSER=root
REJECT SERVICE=M

# all other operations allowed
DEFAULT ACCEPT

I edited back the /etc/hosts on the null workstation the way anaconda set it up
and still get the same error

#lpq

Printer: hp2250@localhost (dest hp2250@server)
 Queue: no printable jobs in queue
 Status: hp2250: Update_status: no identifier for 'hfA104' at 14:18:08.893
Printer: hp2250@server
 Queue: no printable jobs in queue
 Status: hp2250: Check_for_missing files: hp2250: no permission to print at
13:15:33.206
Comment 7 Tim Waugh 2004-12-08 08:15:52 EST
CUPS is the print spooler now; closing.

Note You need to log in before you can comment on or make changes to this bug.