This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 720992 - [RFE] Ephemeral Storage Unmounted in EC2
[RFE] Ephemeral Storage Unmounted in EC2
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: releng (Show other bugs)
6.1
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jay Greguske
Release Test Team
: EC2, FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-13 09:43 EDT by Jay Greguske
Modified: 2011-09-06 10:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-06 10:56:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jay Greguske 2011-07-13 09:43:06 EDT
Description of problem:

Ephemeral storage devices are unmounted when you instance an image in EC2. /etf/fstab should automatically mount them somewhere since they are in fact, mountable. They are unparitioned ext3 volumes.

How reproducible:
Always

Steps to Reproduce:
Boot an instance in EC2

Actual results:
Observe that ephemeral storage is unmounted.

Expected results:
Observe that ephemeral storage is mounted

Additional info:
We do expose the devices already at AMI registration time:
-b /dev/sdf=ephemeral0 -b /dev/sdg=ephemeral1

We just need to mount /dev/sdf and /dev/sdg somewhere.
Comment 2 Jay Greguske 2011-08-17 11:51:03 EDT
http://docs.amazonwebservices.com/AWSEC2/2011-07-15/UserGuide/index.html?InstanceStorage.html

Basically this breaks down to:

if i386:
  /dev/sda2 ext3 on /mnt
  /dev/sda3 swap on /swap
elif x86_64:
  /dev/sdb ext3 on /mnt

The remaining instance storages (sdc, sdd, sde) will only be available on some larger instance types and are unpartitioned space. They should not be considered.

This gets tricky with micro instances though, since they can be i386 or x86_64, and have NO storage at all. Rather than mount via /etc/fstab, perhaps it would make sense to have a boot service that looks at the instance metadata and behaves depending on that.
Comment 5 RHEL Product and Program Management 2011-09-06 10:56:16 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.