Bug 72119 - up2date "Error Class Info: Valid username required."
up2date "Error Class Info: Valid username required."
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: up2date (Show other bugs)
null
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
: 72121 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-21 04:40 EDT by Barry K. Nathan
Modified: 2015-01-07 18:59 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-21 14:36:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Barry K. Nathan 2002-08-21 04:40:03 EDT
Description of problem:
up2date can be induced into presenting the error in the Summary (preceded by
"Error Class Code: 11") instead of the channel list.

Version-Release number of selected component (if applicable):
up2date 2.9.46-1 (from a freshly installed (null))


How reproducible:
Always

Steps to Reproduce:
0. Make sure this is not your first boot (i.e., that the system was registered
before running up2date).
1. Perform steps 1 and 2 of "Steps to Reproduce" for bug 72118.
2. Click "Back" once more. You should be at the blurb screen that precedes the
channel list.
3. Click "Forward".

Actual Results: Window pops up with this.
---quote begins here---
Problem registering user name:

Error Class Code: 11
Error Class Info: Valid username required.
Explanation: 
     An error has occurred while processing your request. If this problem
     persists please submit a bug report to rhn-help@redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.
---quote ends here---

Expected Results: I should reach the channel list screen again and be able to
proceed.
Comment 1 Barry K. Nathan 2002-08-21 05:26:13 EDT
FWIW, screenshot of the actual output: attachment 71864 [details] (to bug 72123)
Comment 2 Adrian Likins 2002-08-21 14:36:14 EDT
looks like a gui path issue. You shouldnt be able to go back
from the channel screen. 

should be fixed in 2.9.50 (cant go back from the channel screen)

this also dups #72121
Comment 3 Adrian Likins 2002-08-21 14:36:48 EDT
*** Bug 72121 has been marked as a duplicate of this bug. ***
Comment 4 Barry K. Nathan 2002-08-26 02:53:30 EDT
Verified fixed in 2.9.55, therefore closing.

Note You need to log in before you can comment on or make changes to this bug.