Bug 72120 - view advisory => traceback
view advisory => traceback
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
: 72425 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-21 04:50 EDT by Michael Schwendt
Modified: 2015-01-07 18:59 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-26 20:24:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2002-08-21 04:50:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020809

Description of problem:
For the "kernel" package I clicked on the "View Advisory" button on the
"Packages Flagged to be Skipped" page:

Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/gui.py", line 934, in showAdvisory
    advisories = rhnErrata.getAdvisoryInfo(rowData[1])
TypeError: unsubscriptable object


Version-Release number of selected component (if applicable):
2.9.46-1

How reproducible:
Always
Comment 1 Adrian Likins 2002-08-21 15:59:22 EDT
taking a look...
Comment 2 Adrian Likins 2002-08-21 22:35:17 EDT
fixed in 2.9.53
Comment 3 Adrian Likins 2002-08-23 15:25:06 EDT
*** Bug 72425 has been marked as a duplicate of this bug. ***
Comment 4 Michael Schwendt 2002-12-31 09:14:55 EST
On redhat-list someone reported this bug to be still present in Psyche:
https://listman.redhat.com/pipermail/redhat-list/2002-December/162634.html
Comment 5 Adrian Likins 2003-08-06 18:35:42 EDT
Should be fixed in 3.1.50 or so. Or at least, every way/time/place I can
possibly think of hitting "view advisory" seems to work
Comment 6 Michael Schwendt 2003-09-02 05:09:43 EDT
up2date 3.1.46-2 in Severn gives:

  No package selected. Select a package first.

Is that a work-around for empty advisories or unexpected behaviour?
Comment 7 Adrian Likins 2003-09-02 17:28:48 EDT
work around?

Not really. You have to select a package before it
can get the advisory info for it. 
Comment 8 Michael Schwendt 2003-09-02 17:51:07 EDT
Funny that you think I'm *that* stupid. Of course did I select a package
beforehand. But this is Severn -- a beta -- so, what should I get instead of "No
package selected. Select a package first."? An empty advisory maybe?
Comment 9 Adrian Likins 2003-09-02 18:20:56 EDT
Not assuming anyone is stupid (aside from myself, and thats no assumption...). 

But there is a distinction between selecting
package to be updated (check the check mark) and 
selecting it for seeing advisory info (click the
row so that it's highlighted in blue) that is
fairly non obvious. (to be fixed, but low on
the priority list...).

I should probabaly add a comment about that
in the error text, if I can come up with wording
that doesnt confuse the matter more. 
Comment 10 Michael Schwendt 2003-09-02 18:57:32 EDT
Well, that's a bad wording indeed, especially due to the "Select all packages"
checkbox at the top. At least the error message could say to "highlight" a
package. That would have helped [me]. 

Or you could highlight the top entry by default. ;)

Note You need to log in before you can comment on or make changes to this bug.