Bug 721378 - PDE not resolving from dropins
PDE not resolving from dropins
Status: CLOSED DUPLICATE of bug 719128
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
noarch Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Alexander Kurtakov
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2011-07-14 08:59 EDT by Kiu Kwan Leung
Modified: 2011-09-20 05:43 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2011-09-20 05:43:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Kiu Kwan Leung 2011-07-14 08:59:19 EDT
Description of problem:

eclipse pdebuild fails with FileNotFoundException due to malformed file path:


This happens when somebody tries to download eclipse-pde from rawhide after 8th July.

How reproducible:

Steps to Reproduce:
1. On/after 8th July, do yum --enablerepo=rawhide install eclipse-pde
2. After installation, perform any pdebuild or rpmbuild for eclipse plugins.

Actual results:
The following error -

/usr/lib64/eclipse/dropins/sdk/plugins/org.eclipse.pde.build_3.7.0.v20110512-1320/scripts/build.xml:35: The following error occurred while executing this line:
/usr/lib64/eclipse/dropins/sdk/plugins/org.eclipse.pde.build_3.7.0.v20110512-1320/scripts/build.xml:91: The following error occurred while executing this line:
/usr/lib64/eclipse/dropins/sdk/plugins/org.eclipse.pde.build_3.7.0.v20110512-1320/templates/package-build/customTargets.xml:19: The following error occurred while executing this line:
java.io.FileNotFoundException: /usr/lib64/eclipse/dropins/sdk/plugins/org.eclipse.pde.build_3.7.0.v20110512-1320/scripts/${eclipse.pdebuild.scripts}/genericTargets.xml (No such file or directory)
	at java.io.FileInputStream.open(Native Method)
	at java.io.FileInputStream.<init>(FileInputStream.java:137)
        at ...

Total time: 1 second
An error has occurred. See the log file
error: Bad exit status from /var/tmp/rpm-tmp.RLehvc (%build)

RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.RLehvc (%build)

Expected results:
A successful build.

Additional info:
Comment 1 Andrew Overholt 2011-07-14 12:26:00 EDT
The root cause of this is the org.eclipse.pde.build bundle not being present (it provides the ${eclipse.pdebuild.scripts} ant variable).  This means that eclipse-pde's contents aren't being loaded from dropins.  I'm pretty sure this is a duplicate of bug #719128.
Comment 2 Alexander Kurtakov 2011-08-25 10:32:34 EDT
Is this bug still present?
Comment 3 Alexander Kurtakov 2011-09-20 05:43:03 EDT
Almost a month without response. Closing.

*** This bug has been marked as a duplicate of bug 719128 ***

Note You need to log in before you can comment on or make changes to this bug.