Bug 72154 - rc.sysinit asssumes the drivers hid, keybdev, and mousedev are compiled as modules
rc.sysinit asssumes the drivers hid, keybdev, and mousedev are compiled as mo...
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-21 11:44 EDT by Nathan G. Grennan
Modified: 2014-03-16 22:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-14 00:59:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nathan G. Grennan 2002-08-21 11:44:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
I always recompile my kernel and pick the options I want. Since I constantly use
my usb mouse I have compiled support for hid and mousedev into my kernel. Once I
start using my kernel I always get Failed messages from rc.sysinit because it
assumes that they are modules and tries to load them. I think a check to see if
the modules exist before trying to load them would be a good idea, and/or even
better use listings in /proc to see if they are compiled in.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Compile kernel with hid and mousedev compiled in
2. Reboot

	

Actual Results:  Failed messages from rc.sysinit

Expected Results:  OK messages from rc.sysinit

Additional info:
Comment 1 Nathan G. Grennan 2003-01-02 22:40:28 EST
I have a simple way to do this that I have started to use.


needusbstorage=
if [ $usb = "1" ]; then
    needusbstorage=`grep -e "^I.*Cls=08" /proc/bus/usb/devices 2>/dev/null`
    grep 'hid' /proc/bus/usb/drivers
    needhid=$?
    if [ $needhid = "1" ]; then
       action $"Initializing USB HID interface: " modprobe hid 2> /dev/null
       action $"Initializing USB keyboard: " modprobe keybdev
       action $"Initializing USB mouse: " modprobe mousedev
    fi
fi

instead of

needusbstorage=
if [ $usb = "1" ]; then
    needusbstorage=`grep -e "^I.*Cls=08" /proc/bus/usb/devices 2>/dev/null`
    action $"Initializing USB HID interface: " modprobe hid 2> /dev/null
    action $"Initializing USB keyboard: " modprobe keybdev
    action $"Initializing USB mouse: " modprobe mousedev
fi


This may not be a solution for all cases, but it works for me and is a step in
the right direction.
Comment 2 Bill Nottingham 2003-01-14 00:59:04 EST
Added in 7.03-1.

Note You need to log in before you can comment on or make changes to this bug.