Bug 72233 - gcc's -a option doesn't work
gcc's -a option doesn't work
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Depends On:
  Show dependency treegraph
Reported: 2002-08-22 04:41 EDT by Tim Waugh
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version: 3.2.2-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-08-05 12:09:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2002-08-22 04:41:17 EDT
Description of Problem: 
The -a option, documentated in the man page and in other places, isn't 
Version-Release number of selected component (if applicable): 
How Reproducible: 
Steps to Reproduce: 
1. touch a.c 
2. gcc -g -pg -a -c a.c 
Actual Results: 
a.o containing basic block profiling information. 
Expected Results: 
cc1: unrecognized option `-a'
Comment 1 Jakub Jelinek 2002-08-22 05:39:20 EDT
-a was removed on purpose.
I'll apply
2002-08-14  Nathan Sidwell  <nathan@codesourcery.com>

        * doc/invoke.texi (-a): Remove documentation.
        (-fprofile-arcs): Remove reference to -a, -ax options.
        * doc/gcov.texi (Gcov Data Files): Data might be merged.

for the next gcc build, so that you no longer find it in documentation...
Comment 2 Tim Waugh 2002-08-22 05:42:40 EDT
It's also mentioned in the gprof info page.
Comment 3 Jakub Jelinek 2003-08-05 12:09:29 EDT
Should be fixed in gcc-3.2-2 and later.

Note You need to log in before you can comment on or make changes to this bug.