Bug 72250 - kprinter hangs on wrong username/password
kprinter hangs on wrong username/password
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Petr Rockai
Ben Levenson
Depends On:
  Show dependency treegraph
Reported: 2002-08-22 08:32 EDT by Inger Karin Haarbye
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-10-18 14:15:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Inger Karin Haarbye 2002-08-22 08:32:37 EDT
Description of Problem: 
RedHat 7.3.94 (Null). 
When I started kprinter as user to add a new CUPS-printer, everything was fine 
until username/password dialog. The username was already filled in - and 
accidentaly I gave a wrong password. Then kprinter was hanging - had to kill 
it. The following line was written repeatedly to /var/log/messages: 
aug 22 09:24:01 opuntia cups(pam_unix)[820]: authentication failure; logname= 
uid=0 euid=0 tty= ruser= rhost=  user=inger 
I think this should be handeled in a better way. 
Version-Release number of selected component (if applicable): 
How Reproducible: 
I have tried twice - with same result. 
Steps to Reproduce: 
1. Start kprinter as user 
2. Add printer 
3. On username/password dialog, give a wrong password 
Actual Results: 
Kprinter is hanging - cups is repeatedly writing to /var/log/messages 
Expected Results: 
a message about wrong username/password - and possibility to correct it. 
Additional Information:
Comment 1 Petr Rockai 2006-07-17 14:38:36 EDT
This bug is reported against old release of Red Hat Linux or Fedora Core 
that is no longer supported. Chances are that it has been already fixed in 
newer Fedora Core release. If you still experience the problem with 
current release of Fedora Core, please update the Version field (you may 
need to switch Product to Fedora Core first) in the bug report and put it 
back to NEW state.
Comment 2 Bill Nottingham 2006-10-18 14:15:17 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
If this issue is still present in a current Fedora Core release, please
open a new bug with the relevant information.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.