Bug 722603 - Installation of package changes default fonts
Installation of package changes default fonts
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-15 15:59 EDT by redhatbug
Modified: 2011-07-16 10:33 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-16 09:45:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
See Reply to Comment 2 (355.00 KB, application/zip)
2011-07-16 09:32 EDT, redhatbug
no flags Details

  None (edit)
Description redhatbug 2011-07-15 15:59:27 EDT
Description of problem:
Installation of qt-4.7.3-6.fc15.x86_64 (with its dependencies) changes all the default fonts on the kde desktop and in Konsole to a small anaemic type

Version-Release number of selected component (if applicable):
qt-4.7.3-6.fc15.x86_64

How reproducible:
Every time qt-4.7.3-6.fc15.x86_64 is installed
As reported on Bodhi when it was in testing repo

Steps to Reproduce:
1. "yum update qt" (when older version is installed)
2. "yum history undo last" reverses the update and the fonts revert to as previous
3.
  
Actual results:
Default fonts changed as noted in "description of problem" above

Expected results:
Default fonts should remain as selected by user

Additional info:
Comment 1 Rex Dieter 2011-07-15 16:06:16 EDT
Depends very much on your currently installed set of fonts.

That said, the update was necessary and fixes a serious bug #705348 

Can you provide a screenshot? and something like the output of:
rpm -qa | grep fonts
Comment 2 Kevin Kofler 2011-07-15 16:38:01 EDT
Can you please try the instructions in:
https://kevinkofler.wordpress.com/2011/05/19/hint-how-to-force-autohinting-on-fedora-15/
?

If those instructions "fix" the problem, then we are sorry, but the rendering you previously saw was the bug (in fact the result of bug #705348), and the rendering you now see is how the fonts are intended to look. See the above blog link for a more detailed explanation.
Comment 3 Kevin Kofler 2011-07-15 16:39:49 EDT
PS: Please note that the actual fonts used probably did not change (or did they? Screenshots please!), only the way they are rendered on the screen did.
Comment 4 redhatbug 2011-07-16 09:32:38 EDT
Created attachment 513482 [details]
See Reply to Comment 2
Comment 5 redhatbug 2011-07-16 09:43:59 EDT
(In reply to comment #1)
> Depends very much on your currently installed set of fonts.
> 
> That said, the update was necessary and fixes a serious bug #705348 
> 
> Can you provide a screenshot? and something like the output of:
> rpm -qa | grep fonts

The attachment 722603-Info.zip contains:
Three screenshots
Output from "rpm -qa | grep fonts >fontsinstalled.txt"

Attachment description should read "See Reply to Comment 1" (not Comment 2)

My installation is basicly that from the KDE Live image with updates.

The fonts appearance before the latest revision of qt is as at initial installation and is the same as that when the Live image of previously releases (certainly Fedora 13 and Fedora 14 and probably Fedora 10 to 12) were installed.
At no time during the updating of these previously releases did the fonts appearance change as it is now doing.

I have still to try the instructions in comment 2 and will post a reply to that comment when I have done so.

Hope all this helps
Comment 6 Kevin Kofler 2011-07-16 09:45:20 EDT
Looking at your screenshot, the change of behavior is indeed due to the fix for bug #705348. (GTK+ applications have been rendering the DejaVu fonts that way since the Fedora 15 release, and Qt did too in F15 prereleases, before last-minute changes to the Lohit fonts exposed bug #705348.)

The new rendering is the way DejaVu upstream wants their fonts rendered (they explicitly recommend enabling the Freetype bytecode interpreter for their fonts). This was not possible in previous releases of Fedora because of a patent, then because of bug #547532.

If you do not like the new rendering, please see:
https://kevinkofler.wordpress.com/2011/05/19/hint-how-to-force-autohinting-on-fedora-15/

Sorry.
Comment 7 redhatbug 2011-07-16 10:33:42 EDT
(In reply to comment #6)
> Looking at your screenshot, the change of behavior is indeed due to the fix for
> bug #705348. (GTK+ applications have been rendering the DejaVu fonts that way
> since the Fedora 15 release, and Qt did too in F15 prereleases, before
> last-minute changes to the Lohit fonts exposed bug #705348.)
> 
> The new rendering is the way DejaVu upstream wants their fonts rendered (they
> explicitly recommend enabling the Freetype bytecode interpreter for their
> fonts). This was not possible in previous releases of Fedora because of a
> patent, then because of bug #547532.
> 
> If you do not like the new rendering, please see:
> https://kevinkofler.wordpress.com/2011/05/19/hint-how-to-force-autohinting-on-fedora-15/
> 
> Sorry.

I have just tried the instructions (99-autohinter-only.conf) on your web site and all seems to be working fine now

Thank you very much 

Nothing to be sorry about

Would it be possible to have a notification issued to the terminal or whatever when the package is installed?

Note You need to log in before you can comment on or make changes to this bug.