Bug 722911 - Fedora 15 LXDE w/KB Canadian French layout - dead keys not recognized in QT app.
Fedora 15 LXDE w/KB Canadian French layout - dead keys not recognized in QT app.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-18 09:12 EDT by nomnex
Modified: 2011-07-26 06:00 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-26 06:00:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nomnex 2011-07-18 09:12:07 EDT
Description of problem:

OS "en_US", hardware notebook keyboard "Japanese", default keyboard layout "jp". Additional keyboad layout "ca" [French-Canadian, I type in French].

The dead keys "ç, è, à, etc." are not recognized in all the applications using a QT toolkit.

Version-Release number of selected component (if applicable):

QT 4.7.3

How reproducible:

Alawys

Steps to Reproduce:
1. setxkbmap -option grp:switch, grp:rctrl_rshift_toggle jp,ca
2. switch to kb "ca"
3. input accents in a qt application field
  
Actual results:

dead keys not working

Expected results:

dead keys working (obviously)

Additional info:

Upstream bug report: http://bugreports.qt.nokia.com/browse/QTBUG-20428
Comment 1 Rex Dieter 2011-07-18 09:23:41 EDT
reassigning -> qt
Comment 2 Kevin Kofler 2011-07-18 17:35:59 EDT
What input method mechanism are you using for jp? (These bugs are usually caused by input methods, we have at least 2 of them in our Bugzilla already.)
Comment 3 nomnex 2011-07-21 18:54:17 EDT
Hello, I use iBus (recommended). Could you direct me to the bug report already opened for ca input if the issue is the same. Thank you.
Comment 4 Kevin Kofler 2011-07-22 08:18:38 EDT
Uhm, there's bug #658090, which you filed and which got fixed because you claimed it was fixed (and nobody else could reproduce it).
Comment 5 Kevin Kofler 2011-07-22 08:19:20 EDT
Sorry, I mean:
Uhm, there's bug #658090, which you filed and which got CLOSED (as "fixed in errata") because you claimed it was fixed (and nobody else could reproduce it).
Comment 6 nomnex 2011-07-22 10:34:09 EDT
that was about Swiss-French input layout. It has been fixed ever since. I am located in Japan. Unluckily (from my point of view), I write/speak a language with accents. Ca and Fr(ch) language use the same set of accents, but the kb layout is different -- "ca" input relies on dead keys for almost all the accents. The benefit is that a "ca" kb layout is much more closer to a JP/US (my notebook) kb layout, than a fr(ch) kb layout.

Anyway, I think it's best closing this bug since it's misplaced. I will open a new bug with the same issue to Ibus (dest. Fujiwara) since I got a good feedback from him about a ibus time out problem.

Thanks for the feedback and let me know if i should do otherwise.
Comment 7 Kevin Kofler 2011-07-22 12:51:49 EDT
It's the same bug, dead keys are broken. I don't think it depends on the keyboard layout at all.
Comment 8 nomnex 2011-07-26 00:37:15 EDT
Kevin, thanks again for the ibus pointer. Fujiwara answered my question, see https://bugzilla.redhat.com/show_bug.cgi?id=725125#c2

A missing ibus plug-in was preventing some KB layouts to input accents relying on dead keys correctly.

Note You need to log in before you can comment on or make changes to this bug.