Bug 723082 - RFE - undo option for saved translations
RFE - undo option for saved translations
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
1.3
Unspecified Unspecified
medium Severity medium
: ---
: 1.7
Assigned To: Patrick Huang
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-18 21:22 EDT by Ding-Yi Chen
Modified: 2012-09-12 21:03 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.7-SNAPSHOT (20120710-0026)
Doc Type: Enhancement
Doc Text:
Cause Users may have entered wrong text into editor and get saved, or accidentally overwrite an approved translation. Consequence User can not revert accidental changes made to an text flow. Change Save a translation in editor will generate an undo link beside the "save as approved" button for that entry. When click on the link, it will revert the translation state back to what it was before, given there is no newer translation being saved by others. What now happens when the actions or circumstances above occur. User can revert back to previous translation/state.
Story Points: 5
Clone Of:
Environment:
Last Closed: 2012-09-11 01:11:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ding-Yi Chen 2011-07-18 21:22:42 EDT
Description of problem:
Since the global undo/redo might cause chaos in multi-user editing environment 
(e.g. Is it appropriate to undo the translation of other messages when somebody is working on it?), thus global undo/redo buttons should be disabled.

Instead, an undo button is placed for each message, as it is more intuitive. 

Version-Release number of selected component (if applicable):
1.4-SNAPSHOT
Comment 1 Patrick Huang 2012-07-03 19:39:53 EDT
committed into master:
https://github.com/zanata/zanata/commit/fadfe7202bcc4f3d63e9af03e2a7fee5eb3558e9
Comment 2 Ding-Yi Chen 2012-07-05 22:28:29 EDT
Tested with Zanata version 1.7-SNAPSHOT (20120706-0026)

The undo function itself perform as it should, and it matches our current undo policy by not allowing undo on other people's work. 

The undo messages are located in the notification element, but it does not indicate which row will the undo go to.

For example, a translator just translated message 1-10, but then he/she found that she need to undo the message 2. But by current design, he/she has no way to tell which notification is for message 2

A small undo icon that near the "save" icon might be good enough.

REASSIGNED.
Comment 3 Patrick Huang 2012-07-09 01:42:14 EDT
Move undo link from notification area to individual row besides save button. It will undo latest change to one row and remove itself when it's undone.

committed to master:
https://github.com/zanata/zanata/commit/99acc1ce8fc5fd8bfa03850b4ac41c63e60f4d5b
Comment 4 Ding-Yi Chen 2012-07-09 20:44:52 EDT
VERIFIED with Zanata version 1.7-SNAPSHOT (20120710-0026)

Note You need to log in before you can comment on or make changes to this bug.