Bug 7232 - SMP kernel/module symbol data is missing from kernel-headers
SMP kernel/module symbol data is missing from kernel-headers
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-22 14:03 EST by Erik Ratcliffe
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-06 00:48:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Erik Ratcliffe 1999-11-22 14:03:27 EST
By default, RH6 installs a kernel-headers RPM package that contains kernel
and module symbol information for non-SMP kernels.  If a user installs an
SMP kernel that ships with RH6, modules can not compile and load against
the SMP kernel because the symbol information compiled within the module
does not match the exported kernel symbol data.

Rebuilding the SMP kernel from scratch (i.e. starting with 'make mrproper')
creates the correct data in /usr/src/linux/include/linux/modules, which
then enables modules to compile and load against the SMP kernel.  It would
probably be better to include either another kernel-headers RPM package for
the SMP kernel, or add SMP symbol data to the main kernel-headers package
(like what seems to have happened with RH6.1).
Comment 1 Cristian Gafton 2000-01-04 17:20:59 EST
Assigned to dledford
Comment 2 Bill Nottingham 2000-02-06 00:48:59 EST
Fixed in 6.1

Note You need to log in before you can comment on or make changes to this bug.