Bug 723285 - [abrt] Zim-0.50-2.fc14: __init__.py:150:autosave:AssertionError
[abrt] Zim-0.50-2.fc14: __init__.py:150:autosave:AssertionError
Status: CLOSED DUPLICATE of bug 852043
Product: Fedora
Classification: Fedora
Component: Zim (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Robin Lee
Fedora Extras Quality Assurance
abrt_hash:651f4a4a
:
: 726671 740337 783254 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-19 11:43 EDT by andreas.kugel
Modified: 2012-08-27 20:21 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-27 20:21:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (463 bytes, text/plain)
2011-07-19 11:43 EDT, andreas.kugel
no flags Details

  None (edit)
Description andreas.kugel 2011-07-19 11:43:45 EDT
abrt version: 1.1.18
architecture: x86_64
cmdline: /usr/bin/python /usr/bin/zim
component: Zim
executable: /usr/bin/zim
kernel: 2.6.35.12-90.fc14.x86_64
package: Zim-0.50-2.fc14
reason: __init__.py:150:autosave:AssertionError
release: Fedora release 14 (Laughlin)
time: 1311089857
uid: 502

backtrace
-----
__init__.py:150:autosave:AssertionError

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/zim/plugins/versioncontrol/__init__.py", line 104, in on_quit
    self.autosave()
  File "/usr/lib/python2.7/site-packages/zim/plugins/versioncontrol/__init__.py", line 150, in autosave
    assert self.vcs
AssertionError

Local variables in innermost frame:
self: <VersionControlPlugin object at 0x25dcfa0 (zim+plugins+PluginClass at 0x2868440)>

How to reproduce
-----
1. Zim crashes every time when I quit it from the panel.
2.
3.
Comment 1 andreas.kugel 2011-07-19 11:43:47 EDT
Created attachment 513829 [details]
File: backtrace
Comment 2 Robin Lee 2011-07-19 22:28:17 EDT
Please update to the latest version (0.52-1) and try again.
Comment 3 Robin Lee 2011-09-22 00:34:30 EDT
*** Bug 740337 has been marked as a duplicate of this bug. ***
Comment 4 Robin Lee 2011-09-22 00:39:40 EDT
Do you have Version Control plugin enabled and Bazaar installed?
Comment 5 Robin Lee 2011-09-22 00:49:57 EDT
*** Bug 726671 has been marked as a duplicate of this bug. ***
Comment 6 Niranjan Mallapadi Raghavender 2011-09-22 02:22:25 EDT
Package: Zim-0.53-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.while closing the zim application
2.
3.
Comment 7 Niranjan Mallapadi Raghavender 2011-09-22 07:19:01 EDT
I have enabled following plugins:
Calender
Inline-Calender
Insert symbol
line sorter
print to browser
Tags
Task list
Tray icon
version control


I de-selected version control but the zim still crashed while closing
Comment 8 Fedora Admin XMLRPC Client 2012-01-10 22:24:13 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 9 Robin Lee 2012-01-19 14:20:44 EST
*** Bug 783254 has been marked as a duplicate of this bug. ***
Comment 10 Robin Lee 2012-08-27 20:21:50 EDT

*** This bug has been marked as a duplicate of bug 852043 ***

Note You need to log in before you can comment on or make changes to this bug.