Bug 723363 - Unsubscribe is broken when system is not registered.
Unsubscribe is broken when system is not registered.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.1
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: John Sefler
John Sefler
:
Depends On:
Blocks: rhsm-rhel62
  Show dependency treegraph
 
Reported: 2011-07-19 19:43 EDT by Michael Stead
Modified: 2011-12-06 12:22 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 12:22:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Stead 2011-07-19 19:43:59 EDT
Description of problem:

When user attempts to unscubscribe from a subscription, and system is not registered, the subscription is not removed from the list in My Subscriptions.

Version-Release number of selected component (if applicable):
subscription-manager-0.96.4-1

How reproducible:
Always

Steps to Reproduce:
1. Launch subscription manager GUI
2. Ensure system is unregistered
3. Import an entitlement certificate.
4. On the My Subscriptions tab, select the newly imported subscription, and click Unsubscribe.
  
Actual results:
The selected subscription remains in the list. Nothing appears to have happened.

Expected results:
The selected subscription should be removed.

Additional info:
Comment 2 Michael Stead 2011-07-19 20:08:22 EDT
Now fixed in master branch: 8e92f4a14dc96ec9f0601923d873248a6cd9e638
Comment 5 John Sefler 2011-07-26 15:30:19 EDT
moving to VERIFIED
Comment 6 errata-xmlrpc 2011-12-06 12:22:37 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html

Note You need to log in before you can comment on or make changes to this bug.