Bug 72367 - up2date won't download without space to install
up2date won't download without space to install
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-23 03:49 EDT by Joe Bayes
Modified: 2015-01-07 18:59 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-23 03:49:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Bayes 2002-08-23 03:49:13 EDT
Description of Problem:
When I specify retrieveOnly=1 in the config file and try to download a new
kernel source package, I get:

RPM package conflict error.  The message was:
Test install failed because of package conflicts:
installing package kernel-source-2.4.18-10 needs 29Mb on the /usr filesystem

But since I only want up2date download the package, and not install it, there's
no reason why it needs to have space on /usr. (I have 150M free in /var, which
should be plenty.)

Version-Release number of selected component (if applicable):
up2date-2.7.86-7.x.3


How Reproducible:
always

Steps to Reproduce:
1. specify retrieveOnly=1 in /etc/sysconfig/rhn/up2date
2. ensure that there is not enough room to install the kernel source in /usr
3. Make sure you have a non-current kernel source installed
4. up2date -u

Actual Results:

RPM package conflict error.  The message was:
Test install failed because of package conflicts:
installing package kernel-source-2.4.18-10 needs 29Mb on the /usr filesystem

Expected Results:

I expected up2date to download the kernel source and place the src.rpm in
/var/spool/up2date/

Additional Information:
Comment 1 Adrian Likins 2002-09-12 18:03:24 EDT
It's basically working as designed.

The idea being that up2date will only download/install packages that
are correct, complete, and installable. In the case of lack of space,
thats not the case. 

At some point, there may be a feature added to use up2date as
a ftp client.

Note You need to log in before you can comment on or make changes to this bug.