Bug 723720 - backlight for (ASUS G73SW notebook) keyboard cannot be set from keyboard
backlight for (ASUS G73SW notebook) keyboard cannot be set from keyboard
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-20 17:39 EDT by netbeans
Modified: 2011-08-30 07:08 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-30 07:08:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description netbeans 2011-07-20 17:39:39 EDT
Description of problem:
keyboard background lights dont work ( not adjustable ) 

I have an ASUS G73SW notebook. The keyboard can be LED lite to various degrees of brightness. Under WIN 7, this feature does work. on linux, it plays dead.

The backlight for the screen is keyboard settable. The enable/disable wireless keys appears to work, but not always - not sure why.

There are other specialized keys, but I dont know how to match them up with some functionality.

Version-Release number of selected component (if applicable):


How reproducible:
so far always.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
I am not sure if this is a request for a new feature, or a bug, or a lack of understanding on how the keyboard works in getting notebook features to work.
Comment 1 Josh Boyer 2011-08-24 10:09:29 EDT
This looks like it might be supported in the upcoming 3.1 kernel with commits e9809c0b9670656855655d8ed6dc33718ec12ba2 and af965e973276b015d1b7d9ee78ed8d8df9d6bc98.

The latest kernel in updates-testing for Fedora 16 should have those commits.  We won't be backporting those to Fedora 14 due to the large gap in kernel versions and the relatively short lifetime left on that release.

Note You need to log in before you can comment on or make changes to this bug.