This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 723731 - [abrt] ibus-1.3.99.20110419-7.fc15: connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.Failed: Context which does not has focus can not change engine to sunpinyin.
[abrt] ibus-1.3.99.20110419-7.fc15: connection.py:630:call_blocking:DBusExcep...
Status: CLOSED DUPLICATE of bug 707370
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
15
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
abrt_hash:363e1c56ed7a82fd87df4fcd44a...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-20 18:55 EDT by Mike Ma
Modified: 2011-07-31 22:27 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-31 22:27:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mike Ma 2011-07-20 18:55:29 EDT
abrt version: 2.0.3
architecture:   x86_64
cmdline:        /usr/bin/python /usr/share/ibus/ui/gtk/main.py
comment:        switch the input method to sunpinyin
component:      ibus
executable:     /usr/share/ibus/ui/gtk/main.py
kernel:         2.6.38.8-32.fc15.x86_64
os_release:     Fedora release 15 (Lovelock)
package:        ibus-1.3.99.20110419-7.fc15
reason:         connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.Failed: Context which does not has focus can not change engine to sunpinyin.
time:           Mon Jul 11 00:06:23 2011
uid:            500
username:       mike

backtrace:
:connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.Failed: Context which does not has focus can not change engine to sunpinyin.
:
:Traceback (most recent call last):
:  File "/usr/share/ibus/ui/gtk/panel.py", line 623, in __im_menu_item_activate_cb
:    self.__focus_ic.set_engine(engine)
:  File "/usr/lib/python2.7/site-packages/ibus/inputcontext.py", line 284, in set_engine
:    return self.__context.SetEngine(engine.name)
:  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 140, in __call__
:    **keywords)
:  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 630, in call_blocking
:    message, timeout)
:DBusException: org.freedesktop.DBus.Error.Failed: Context which does not has focus can not change engine to sunpinyin.
:
:Local variables in innermost frame:
:byte_arrays: False
:self: <dbus.connection.Connection object at 0x2a0add0>
:args: (dbus.String(u'sunpinyin'),)
:utf8_strings: False
:bus_name: 'org.freedesktop.IBus'
:get_args_opts: {'byte_arrays': False, 'utf8_strings': False}
:object_path: dbus.ObjectPath('/org/freedesktop/IBus/InputContext_274')
:timeout: -1.0
:signature: u's'
:dbus_interface: 'org.freedesktop.IBus.InputContext'
:message: <dbus.lowlevel.MethodCallMessage object at 0x296dbe8>
:method: 'SetEngine'
Comment 1 fujiwara 2011-07-31 22:27:07 EDT

*** This bug has been marked as a duplicate of bug 707370 ***

Note You need to log in before you can comment on or make changes to this bug.