Bug 72397 - Unhandled Exception In Installer 7.3
Summary: Unhandled Exception In Installer 7.3
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-23 14:21 UTC by John Brittain
Modified: 2007-04-18 16:45 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-04 15:44:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda Trace File (57.16 KB, text/plain)
2002-08-23 14:23 UTC, John Brittain
no flags Details

Description John Brittain 2002-08-23 14:21:28 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 4.0)

Description of problem:
Upgrade fails with unhandled exception in anaconda.  Fails in both text and 
graphics mode after package selection phase.  I burned these CD's but 
meadiacheck reported all cd's as OK.  Trace shows the following error:
Traceback (innermost last):
  File "/usr/bin/anaconda", line 633, in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/lib/anaconda/gui.py", line 353, in run
    self.icw.run (self.runres, configFileData)
  File "/usr/lib/anaconda/gui.py", line 814, in run
    mainloop ()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2676, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 130, in __call__
    ret = apply(self.func, a)
  File "/usr/lib/anaconda/gui.py", line 417, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 144, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 209, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/upgrade.py", line 291, in upgradeFindPackages
    iutil.setClock(instPath)
  File "/usr/lib/anaconda/iutil.py", line 376, in setClock
    root = root)
  File "/usr/lib/anaconda/iutil.py", line 61, in execWithRedirect
    raise RuntimeError, command + " can not be run"
RuntimeError: /bin/sh can not be run


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Boot Using Floppy Image
2.Run through normal selections selecting default options
3.Select "Upgrade"
	

Actual Results:  Unhandled exception message followed by termination of upgrade.

Expected Results:  RPM should have been upgraded.

Additional info:

It may be that this has something to do with setting the system clock as the 
trace indicates anaconda is attempting to use bash to run hwclock.

Comment 1 John Brittain 2002-08-23 14:23:21 UTC
Created attachment 72584 [details]
anaconda Trace File

Comment 2 Michael Fulbright 2002-08-26 20:42:22 UTC
Could you test your CDs following these instructions please:

  http://people.redhat.com/~msf/mediacheck.html

Comment 3 John Brittain 2002-08-26 21:39:43 UTC
Yes I have used mediacheck to validate the CD and they are OK.

Comment 4 Michael Fulbright 2002-08-28 17:14:19 UTC
If you look on VC4 (cntl-alt-f4) when this error occurs do you see any read errors?

Comment 5 John Brittain 2002-08-29 13:39:36 UTC
No I don't see any read errors.
On VC2 I see the single line:
sh-2.05#
On VC3 I see a screen of load messages(???) ending with:
*anaconda floppy device fd0
On VC4 I see a screen of log messages (no errors) ending with:
<6> Journalled Block Device driver loaded
<4> EXT2-fs warning: maximal mount count reached, running e2fsek is recommended
<4> EXT2-fs warning: maximal mount count reached, running e2fsek is recommended
<4> EXT2-fs warning: maximal mount count reached, running e2fsek is recommended
<4> EXT2-fs warning: maximal mount count reached, running e2fsek is recommended
<6> Adding Swap: 66492K swap-space (priority -1)
<6> Adding Swap: 65528K swap-space (priority -2)

Comment 6 Michael Fulbright 2002-08-29 16:38:19 UTC
I would recommend you try a hard drive based upgrade since you have already
downloaded the ISO images.

Comment 7 John Brittain 2002-09-04 15:43:59 UTC
I tried the harddrive install and experienced the same error.

Also I attempted to do a linux mediacheck on the ISO images on the harddrive 
but the install program appears not to respond to this option when the images 
are not on CD-ROM.

Comment 8 Michael Fulbright 2002-10-23 20:33:10 UTC
I have not seen this problem before except when there was a problem with the
install media/source.

We have recently released Red Hat Linux 8.0, you may want to try that as we've
made alot of fixes.


Note You need to log in before you can comment on or make changes to this bug.