Bug 72411 - db_dump of Packages hangs (38454)
db_dump of Packages hangs (38454)
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
http://200.63.21.251/rpmdb.tar.gz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-23 12:10 EDT by Martin Cohen
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-23 12:10:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Martin Cohen 2002-08-23 12:10:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
I tried to follow bug 38454 because had the rpm -qa segfault listed there.

I followed the steps until the db_dump Packages.old | db_load Packages thing ...
i tried to dump to the console to see what it does.
 
Absolutely nothing.  i see its working (sort of) and leaved it alone for two 
hours until decided to do something about it.
 
I checked some docs and found the "-r" repair option and worked so i tried 
again with db_dump Packages.old -r | db_load Packages

and finished !
But rpm -qa continue segfaulting.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. db_dump Packages-ORIG | db_load Packages
	

Actual Results:  Nothing at all

Expected Results:  return an error at least

Additional info:

db_dump 3.1.17
rpm 4.0.2
Red Hat 7.1
Comment 1 Jeff Johnson 2002-08-23 18:08:07 EDT
OK, I did a rebuilddb with rpm-4.1, that seems
to have fixed most everything (although ~6-7 headers
were discarded).

The fixed copy of your Packages file is at
	ftp://people.redhat.com/jbj/rpmdb-72411-FIX.tar.gz
Download and install by doing
	cd /var/lib
	mv rpm/Packages rpm-Packages-SAVE
	tar xzvf rpmdb-72411-FIX.tar.gz
	rpm --rebuilddb -vv
and verify by doing
	rpm -qa
Comment 2 Martin Cohen 2002-08-28 14:44:06 EDT
Works !
Thank you very much.

Note You need to log in before you can comment on or make changes to this bug.