Bug 72424 - GDM 'System' and 'Session' not descriptive enough for new user
GDM 'System' and 'Session' not descriptive enough for new user
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gdm (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Mike McLean
: MoveUpstream, ScreenshotChange, StringChange, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-23 12:47 EDT by Chris Parker
Modified: 2007-04-18 12:45 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-09 19:22:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Chris Parker 2002-08-23 12:47:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020606

Description of problem:
The items 'System' and 'Session', when presented to a new user, are confusing.  

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Start up Redhat
2.Presented with options on GDM that are not easy intuitive
3.
	

Expected Results:  A gdm screen that I don't have to explain to new users.

Additional info:

gdm is great, and I love the new look, but I have had to explain multiple times
to new users how to change their desktop or even shutdown or reboot.  'System'
and 'Session' might be intuitive for seasoned users, but for someone fresh in
the world of GNU/Linux it is confusing.
Comment 1 Havoc Pennington 2002-08-23 12:53:25 EDT
For a new user "Session" is just clearly a broken concept - the choice should
not be offered at all. The choice of two desktops can't be explained in a
reasonable way. Right now we are compromising the new user for the techies there.

For System most likely shutdown/reboot should be toplevel buttons, not inside 
the System button.
Comment 2 George Lebl 2002-08-23 14:23:34 EDT
I don't think session is such an advanced concept.  I don't see it as just to
pick between two desktops.  But the ability to run a failsafe session is a very
useful thing that windows has an incredibly unintuitive way to do.  Also you
cannot just have a session switcher inside the session since that's not very
robust.  If one desktop breaks, you suddenly have no way to log into a different
desktop.  I myself think that the desktop switching thing is done in a stupid
way currently since the desk switching is done inside an Xsession script so that
it works for startx as well.  The startx setup should be the same as gdms and it
should read the session stored by the gdm (it is planned to have this in a
non-gdm specific location and have kdm do the same).  I think trying to use the
same scripts for gdm, xdm/kdm and startx is broken as each will be slightly
broken in a different way.

In any case.  What would you recommend for replacement labels.  Note that they
cannot be too long.  In the graphical greeter we can also add reboot/shutdown
buttons sinc ethe theme format supports that.
Comment 3 Havoc Pennington 2002-12-19 20:11:33 EST
Hmm, this has to be done by screenshot freeze.
Comment 4 Havoc Pennington 2003-01-09 18:53:26 EST
This involves some code changes, instead of just a theme change as I was hoping,
and the screenshot freeze is right on top of me, so will have to push to a
future release. Will move to gnome.org perhaps and change it there.

Basically the needed feature is a way to make a reboot/shutdown button in the 
graphical greeter. I agree that displaying those directly instead of
"System" would be substantially better.
Comment 5 Havoc Pennington 2003-01-09 19:22:33 EST
Nevermind, George told me how to do it. Done. (well, next build of 
redhat-artwork anyway)

Note You need to log in before you can comment on or make changes to this bug.