Bug 72425 - View Advisory causes python error
View Advisory causes python error
Status: CLOSED DUPLICATE of bug 72120
Product: Red Hat Public Beta
Classification: Retired
Component: up2date (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
Depends On:
  Show dependency treegraph
Reported: 2002-08-23 13:06 EDT by Daryll
Modified: 2015-01-07 18:59 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-08-23 13:06:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Daryll 2002-08-23 13:06:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020809

Description of problem:
There is currently a set of kernel updates on the channel.
When I select one and hit view advisory I get a python error.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Run up2date
2. select package
3. push view advisory button

Actual Results:  Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/gui.py", line 934, in showAdvisory
    advisories = rhnErrata.getAdvisoryInfo(rowData[1])
TypeError: unsubscriptable object

Expected Results:  An advisory is shown

Additional info:

I can't install these packages either. After selecting these packages the
forward button remains disabled. It's sort of like they show up in the list, but
up2date otherwise doesn't recognize them.
Comment 1 Adrian Likins 2002-08-23 15:25:13 EDT
dup of #72120
fixed in 2.9.53

*** This bug has been marked as a duplicate of 72120 ***

Note You need to log in before you can comment on or make changes to this bug.