Bug 72441 - gsignal.c:775: no emission of signal "prepare" to stop for instance `0x85d0ba0'
gsignal.c:775: no emission of signal "prepare" to stop for instance `0x85d0ba0'
Status: CLOSED DUPLICATE of bug 69651
Product: Red Hat Public Beta
Classification: Retired
Component: up2date (Show other bugs)
null
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-23 15:48 EDT by James Manning
Modified: 2015-01-07 18:59 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-23 16:01:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
systemid file - proves a valid username was in there (1.27 KB, text/plain)
2002-08-23 15:50 EDT, James Manning
no flags Details

  None (edit)
Description James Manning 2002-08-23 15:48:05 EDT
Description of Problem:
up2date can trigger a glib/gtk problem reproducible and easily

[root@localhost log]# up2date

(up2date:1882): GLib-GObject-WARNING **: gsignal.c:775: no emission of signal
"prepare" to stop for instance `0x85d0ba0'
TypeError: hide() takes no arguments (1 given)

Version-Release number of selected component (if applicable):
up2date-2.9.46-1

How Reproducible:
100%

Steps to Reproduce:
1. start up2date, get "Welcome to Red Hat Update Agent" screen
2. click Forward once to get to channel selection (keep default of null)
3. click Forward again to get to "packages flagged to be skipped" dialog
   - see palindrome bug #72427 for problems here
4. click Back once to get to channel selection dialog again
   - NOTE: notice that the Forward button is now grayed out!
5. click Back once again to get to "Send Profile Information to Red Hat Network"
   - NOTE: 2 forward and 2 back *should* have landed us at "Welcome to..."
6. click Forward
7. error happens
8. NOTE: a dialog pops up as well with Error Class Code: 11 and Info of "Valid
username required" (note that I entered a valid username during firstboot)

Actual Results:
[root@localhost root]# DISPLAY=jmm:0 up2date

(up2date:2569): GLib-GObject-WARNING **: gsignal.c:775: no emission of signal
"prepare" to stop for instance `0x8635e08'
TypeError: hide() takes no arguments (1 given)

Expected Results:
no error :)


Additional Information:
[Fri Aug 23 15:40:09 2002] up2date updating login info
[Fri Aug 23 15:40:09 2002] up2date logging into up2date server
[Fri Aug 23 15:40:10 2002] up2date successfully retrieved authentication token
from up2date server
[Fri Aug 23 15:43:05 2002] up2date availablePackageList from network
Comment 1 James Manning 2002-08-23 15:50:32 EDT
Created attachment 72684 [details]
systemid file - proves a valid username was in there
Comment 2 James Manning 2002-08-23 16:01:24 EDT
worth noting that if instead of going Forward from the Send Profile Information
to Red Hat screen you go forward, you get on the terminal:

[root@localhost rhn]# DISPLAY=jmm:0 up2date
TypeError: hide() takes no arguments (1 given)
Comment 3 Adrian Likins 2002-08-23 16:48:01 EDT
should be fixed in 2.9.53
dup of #69651

also, partially a dup of #72119 (and #72121) both
are basically the same bug (though they look differently) 

*** This bug has been marked as a duplicate of 69651 ***

Note You need to log in before you can comment on or make changes to this bug.