Bug 7245 - /usr/src/redhat/RPMS/sparc64
/usr/src/redhat/RPMS/sparc64
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
6.0
sparc Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-22 22:45 EST by gman
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-11-23 08:46:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description gman 1999-11-22 22:45:46 EST
I was trying to compile a source rpm on a Sparc Ultra5 and it failed only
because rpm would not write in the /usr/src/redhat/RPMS/sparc64 directory.
Just thought it would be nice that directory in the next release/package
release... or fix it so it lands in /usr/src/redhat/RPMS/sparc instead.

I was trying to compile the openssl 0.9.4-2 src rpm..
Comment 1 Jeff Johnson 1999-11-23 08:46:59 EST
Rpm-3.0.3 will create a non-existent sparc64 directory if it doesn't
exist. (Note: it will create *only* the last component of the path, not
the entire path).

Otherwise, this is a configurayion issue. Change the value of the macro

%_rpmfilename           %%{ARCH}/%%{NAME}-%%{VERSION}-%%{RELEASE}.%%{ARCH}.rpm

to put binary rpm's wherever you wish.

Note You need to log in before you can comment on or make changes to this bug.