Bug 72461 - Console messages come in UTF-8 regardless of locale
Console messages come in UTF-8 regardless of locale
Status: CLOSED DEFERRED
Product: Red Hat Linux Beta
Classification: Retired
Component: metacity (Show other bugs)
beta5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-23 18:57 EDT by Göran Uddeborg
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-23 18:57:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Göran Uddeborg 2002-08-23 18:57:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020724

Description of problem:
When using an ISO-8859-1 locale like "sv_SE", messages from metacity to the
console still comes in UTF-8.

Version-Release number of selected component (if applicable): 2.4.0.91-2

How reproducible:
Always

Steps to Reproduce:
1.env LANG=sv_SE metacity

Actual Results:  Window manager warning: Misslyckades med att C6ppna en
anslutning till en sessionshanterare, sC% fC6nsterpositioner kommer inte att
sparas: SESSION_MANAGER environment variable not defined
Window manager warning: SkC$rm 0 pC% display ":2.0" har redan en fC6nsterhanterare


Expected Results:  Window manager warning: Misslyckades med att vppna en
anslutning till en sessionshanterare, se fvnsterpositioner kommer inte att
sparas: SESSION_MANAGER environment variable not defined
Window manager warning: Skdrm 0 pe display ":2.0" har redan en fvnsterhanterare


Additional info:

I'm not sure if bugzilla is 8-bit-clean.  It looks ok when entered, but if not,
the "actual results" and "expected results" above probably doesn't make sense. 
Actual is in UTF-8 and expected is in ISO-8859-1.

For other programs gettext() converts character sets on the fly.

  env LANG=sv_SE pwd --help

gives a description of pwd using ISO-8859-1, while

   env LANG=sv_SE.utf8 pwd --help

gives the same description using UTF-8.  Apparently, metacity is doing something
special which makes this not work.

Strings in menues show correctly as far as I have seen.  I've only seen this in
the xterm window where I launched metacity.  (To test it.)
Comment 1 Havoc Pennington 2002-08-23 19:05:19 EDT
Moved to http://bugzilla.gnome.org/show_bug.cgi?id=91562

(I handle it either way, just easier for me to organize on gnome.org.)

Note You need to log in before you can comment on or make changes to this bug.